summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoron Behar2018-12-28 21:50:25 +0100
committerDoron Behar2018-12-28 22:51:34 +0100
commit38f9064aa2843f7e9357ec5e7eea76d22f42f865 (patch)
tree1ea8485cb210b0bba30066daad213758167f5463
downloadaur-38f9064aa2843f7e9357ec5e7eea76d22f42f865.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD57
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e37e465121b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnuastro
+ pkgdesc = Various programs and library functions for the manipulation and analysis of astronomical data
+ pkgver = 0.8
+ pkgrel = 1
+ url = https://www.gnu.org/software/gnuastro/
+ arch = x86_64
+ license = GPL3
+ depends = gsl
+ depends = cfitsio
+ depends = wcslib
+ depends = libgit2
+ depends = ghostscript
+ source = http://ftp.gnu.org/gnu/gnuastro/gnuastro-latest.tar.gz
+ md5sums = 1f9fe021bf153ac7291af95c95e2d716
+
+pkgname = gnuastro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f75436f6214
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# $Id$
+# Maintainer: Sébastien "Seblu" Luttringer
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=gnuastro
+pkgver=0.8
+pkgrel=1
+pkgdesc='Various programs and library functions for the manipulation and analysis of astronomical data'
+arch=('x86_64')
+license=('GPL3')
+depends=('gsl' 'cfitsio' 'wcslib' 'libgit2' 'ghostscript')
+url='https://www.gnu.org/software/gnuastro/'
+source=("http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-latest.tar.gz")
+md5sums=('1f9fe021bf153ac7291af95c95e2d716')
+
+prepare() {
+ cd $pkgname-$pkgver
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --enable-arithmetic \
+ --enable-buildprog \
+ --enable-convertt \
+ --enable-convolve \
+ --enable-cosmiccal \
+ --enable-crop \
+ --enable-fits \
+ --enable-match \
+ --enable-mkcatalog \
+ --enable-mknoise \
+ --enable-mkprof \
+ --enable-noisechisel \
+ --enable-segment \
+ --enable-statistics \
+ --enable-table \
+ --enable-warp
+}
+
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ #make check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: