summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Adler2018-10-19 23:03:39 +0200
committerDavid Adler2018-10-19 23:03:39 +0200
commitec96e633f189358d48995c3410f612f04d4690ef (patch)
treebd257ab2d668eb2275c771061a8619b44ca631f5
downloadaur-ec96e633f189358d48995c3410f612f04d4690ef.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02241542b644
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnucap-custom-git
+ pkgdesc = customisable executable + a few plugins for gnucap
+ pkgver = r33.0483cea
+ pkgrel = 1
+ url = https://gitlab.com/gnucap/gnucap-custom
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = gnucap
+ provides = gnucap-custom
+ conflicts = gnucap-custom
+ source = gnucap-custom::git+https://gitlab.com/gnucap/gnucap-custom.git
+ md5sums = SKIP
+
+pkgname = gnucap-custom-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..799526fda9f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: David Adler <d.adler@posteo.de>
+
+_pkgname=gnucap-custom
+pkgname=$_pkgname-git
+pkgver=r33.0483cea
+pkgrel=1
+pkgdesc="customisable executable + a few plugins for gnucap"
+arch=('x86_64')
+url="https://gitlab.com/gnucap/gnucap-custom"
+license=('GPL')
+depends=('gnucap')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://gitlab.com/gnucap/$_pkgname.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ ./configure
+ make
+}
+
+check() {
+ cd $_pkgname
+ make check
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir/" install
+}
+