summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2021-01-28 16:42:50 +1000
committerMark Blakeney2021-01-28 16:42:50 +1000
commitd6241585c2625ff7e8210922faa835c0e4f9a8b0 (patch)
tree20bf1f15fefa345bcaa0a309bfb7854c5492e754
parent6095b44f34ef5c8ea78374009038b3b4bd05f128 (diff)
downloadaur-d6241585c2625ff7e8210922faa835c0e4f9a8b0.tar.gz
Update to 1.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD29
2 files changed, 29 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f27d46a580c7..70011f586afb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = gnucash-asx-fetch
pkgdesc = Utility to fetch and add current ASX prices to one or more gnucash files
- pkgver = 1.2
+ pkgver = 1.3
pkgrel = 1
url = https://github.com/bulletmark/gnucash-asx-fetch
arch = any
license = GPL3
- makedepends = python-setuptools
+ makedepends = python-pip
+ makedepends = python-wheel
depends = python>=3.6
- source = gnucash-asx-fetch-1.2.tar.gz::https://github.com/bulletmark/gnucash-asx-fetch/archive/1.2.tar.gz
- sha1sums = 985b8dad8beacae3f5c6d3c52ed3380f4f0aa0fc
+ source = gnucash-asx-fetch-1.3.tar.gz::https://github.com/bulletmark/gnucash-asx-fetch/archive/1.3.tar.gz
+ sha1sums = 629c47f279615cac8fa473db19dc07719df9cf44
pkgname = gnucash-asx-fetch
diff --git a/PKGBUILD b/PKGBUILD
index b27f1ca35e82..b5b14560c58e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,38 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=gnucash-asx-fetch
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc="Utility to fetch and add current ASX prices to one or more gnucash files"
url="https://github.com/bulletmark/$pkgname"
license=("GPL3")
arch=("any")
depends=("python>=3.6")
-makedepends=("python-setuptools")
+makedepends=("python-pip" "python-wheel")
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('985b8dad8beacae3f5c6d3c52ed3380f4f0aa0fc')
+sha1sums=('629c47f279615cac8fa473db19dc07719df9cf44')
package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$pkgname-$pkgver"
+
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --root="$pkgdir" \
+ --isolated \
+ --ignore-installed \
+ --no-deps \
+ --disable-pip-version-check \
+ --no-python-version-warning \
+ --no-warn-script-location \
+ --no-cache-dir \
+ --no-compile \
+ --progress-bar=off \
+ .
+
+ local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
+ local _pkgname="${pkgname//-/_}"
+ cd "$pkgdir/$pdir"
+ rm -f $_pkgname-*.dist-info/direct_url.json
+ sed -i "/\/direct_url.json,/d" $_pkgname-*.dist-info/RECORD
+ python -O -m compileall -q .
}
# vim:set ts=2 sw=2 et: