summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjeb2018-02-13 09:21:51 -0700
committerjeb2018-02-13 09:21:51 -0700
commit46517d6b61b8b0e8b3a3eabd8d846c3649f58fba (patch)
tree2f258bccc89be7c74145e896f952613dd806783a
parentee5cb52465430fd64dc501cc334c9a99910f5608 (diff)
downloadaur-46517d6b61b8b0e8b3a3eabd8d846c3649f58fba.tar.gz
use cmake build since autotools was dropped. add/remove some dependencies to keep up with upstream
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD53
-rw-r--r--gnucash.install17
3 files changed, 26 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c982043e754b..236b55998a1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnucash-git
pkgdesc = A personal and small-business financial-accounting application - GIT version
- pkgver = 2.7.3
+ pkgver = 2.7.4
pkgrel = 1
url = http://www.gnucash.org
install = gnucash.install
@@ -13,15 +13,16 @@ pkgbase = gnucash-git
makedepends = swig
makedepends = gtest
makedepends = gmock
- makedepends = gconf
+ makedepends = cmake
+ makedepends = sqlite3
+ makedepends = libmariadbclient
+ makedepends = postgresql-libs
depends = aqbanking
depends = libdbi-drivers
depends = libgnomecanvas
depends = boost-libs
depends = slib
depends = webkit2gtk
- depends = libgnome-keyring
- depends = sqlite2
optdepends = evince: for print preview
optdepends = perl-date-manip: for stock information lookups
optdepends = perl-finance-quote: for stock information lookups
diff --git a/PKGBUILD b/PKGBUILD
index c483c642d96d..6ce19447df87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,19 +11,19 @@
pkgname=gnucash-git
_pkgname=gnucash
__pkgname=Gnucash
-pkgver=2.7.3
-#.r1.g310442ffe
+pkgver=2.7.4
+#.r4.gfb7426b60
pkgrel=1
pkgdesc="A personal and small-business financial-accounting application - GIT version"
arch=('i686' 'x86_64')
url="http://www.gnucash.org"
license=("GPL")
depends=('aqbanking' 'libdbi-drivers' 'libgnomecanvas' 'boost-libs' \
- 'slib' 'webkit2gtk' 'libgnome-keyring' 'sqlite2')
+ 'slib' 'webkit2gtk')
optdepends=('evince: for print preview'
'perl-date-manip: for stock information lookups'
'perl-finance-quote: for stock information lookups')
-makedepends=('git' 'intltool' 'boost' 'swig' 'gtest' 'gmock' 'gconf')
+makedepends=('git' 'intltool' 'boost' 'swig' 'gtest' 'gmock' 'cmake' 'sqlite3' 'libmariadbclient' 'postgresql-libs')
options=('!emptydirs')
conflicts=('gnucash' 'gnucash-devel' 'gnucash-latest' 'gnucash-gtk3-git' 'gnucash-python' 'gnucash-xbt')
provides=('gnucash')
@@ -39,25 +39,20 @@ pkgver() {
)
}
-prepare() {
- cd "$srcdir/$pkgname"
-
- # add -O to the boost c++11 compatibility detection so that -D_FORTIFY_SOURCE doesn't cause an error
- sed -i '/CXXFLAGS="-Werror -std=gnu++11 $BOOST_CPPFLAGS"/s/-Werror/-Werror -O/' configure.ac
-
- ./autogen.sh
-}
-
build() {
cd "$srcdir/$pkgname"
- # Consider using `sed` for this stuff if it is still needed.
-
- ./configure --prefix=/usr --mandir=/usr/share/man --sysconfdir=/etc \
- --libexecdir=/usr/lib --disable-schemas-compile --enable-ofx --enable-aqbanking \
- --disable-error-on-warning
-
- make
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
+ -DWITH_OFX=ON \
+ -DWITH_AQBANKING=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
+
+ make VERBOSE=1
}
#check() {
@@ -68,22 +63,16 @@ build() {
#}
package() {
- cd "$srcdir/$pkgname"
-
- make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
-
- cd libgnucash/doc/design
+ cd "$srcdir/$pkgname/build"
- make DESTDIR="${pkgdir}" install-info
+ make DESTDIR="${pkgdir}" install
- install -dm755 "${pkgdir}/usr/share/gconf/schemas"
- gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/gnucash.schemas" --domain gnucash \
- "${pkgdir}"/etc/gconf/schemas/*.schemas
- rm -f "${pkgdir}"/etc/gconf/schemas/*.schemas
+ # TODO: tell cmake not to make this file in the first place
+ rm -f "${pkgdir}"/usr/share/glib-2.0/schemas/*.compiled
# Delete the gnucash-valgrind executable because the source files
- # are not included with the package and the executable is hardlinked
- # to the location that it was built at.
+ # are not included with the package and the executable is hardlinked
+ # to the location that it was built at.
rm -f "${pkgdir}"/usr/bin/gnucash-valgrind
}
md5sums=('SKIP')
diff --git a/gnucash.install b/gnucash.install
index d9de2f545eb5..771790d38b76 100644
--- a/gnucash.install
+++ b/gnucash.install
@@ -1,15 +1,6 @@
-pkgname=gnucash
-info_dir=usr/share/info
-info_files=(gnucash-design.info)
-
post_install() {
- usr/sbin/gconfpkg --install ${pkgname}
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
update-desktop-database -q
- [ -x usr/bin/install-info ] || return 0
- for f in ${info_files[@]}; do
- usr/bin/install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
- done
glib-compile-schemas usr/share/glib-2.0/schemas
}
@@ -21,14 +12,6 @@ post_upgrade() {
post_install $1
}
-pre_remove() {
- usr/sbin/gconfpkg --uninstall ${pkgname}
- [ -x usr/bin/install-info ] || return 0
- for f in ${info_files[@]}; do
- usr/bin/install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
- done
-}
-
post_remove() {
update-desktop-database -q
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor