summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeb Rosen2019-10-15 19:38:41 -0700
committerJeb Rosen2019-10-15 19:38:41 -0700
commitd3c2c442aebe8144fd22af73f6b8b7df0b0e0012 (patch)
tree8b6e1ac4c1532a5ee0cad6869b02b778a2e68042
parentd3c478a1b9f2b03400c2cfff26d71495b1c2041b (diff)
downloadaur-d3c2c442aebe8144fd22af73f6b8b7df0b0e0012.tar.gz
Match dependencies and cmake flags to those used in community/gnucash.
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d08c62e4090..c255ff1fc7dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,19 +11,18 @@
pkgname=gnucash-git
_pkgname=gnucash
__pkgname=Gnucash
-pkgver=3.0
+pkgver=3.7.r132.g9661a77f3
#.r84.g451bbd53d
pkgrel=1
pkgdesc="A personal and small-business financial-accounting application - GIT version"
arch=('i686' 'x86_64')
url="http://www.gnucash.org"
license=("GPL")
-depends=('aqbanking' 'libdbi-drivers' 'libgnomecanvas' 'boost-libs' \
- 'slib' 'webkit2gtk')
+depends=('aqbanking' 'boost-libs' 'guile' 'libdbi' 'webkit2gtk')
optdepends=('evince: for print preview'
'perl-date-manip: for stock information lookups'
'perl-finance-quote: for stock information lookups')
-makedepends=('git' 'intltool' 'boost' 'swig' 'gtest' 'gmock' 'cmake' 'sqlite3' 'libmariadbclient' 'postgresql-libs')
+makedepends=('git' 'boost' 'cmake' 'swig' 'gtest' 'gmock' 'libdbi-drivers' 'mariadb-libs' 'postgresql-libs' )
options=('!emptydirs')
conflicts=('gnucash' 'gnucash-devel' 'gnucash-latest' 'gnucash-gtk3-git' 'gnucash-python' 'gnucash-xbt')
provides=('gnucash')
@@ -47,10 +46,8 @@ build() {
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
-DHAVE_GWEN_GTK3=ON \
- -DWITH_OFX=ON \
- -DWITH_AQBANKING=ON \
+ -DCOMPILE_GSCHEMAS=OFF \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
make VERBOSE=1
@@ -68,9 +65,6 @@ package() {
make DESTDIR="${pkgdir}" install
- # TODO: tell cmake not to make this file in the first place
- rm -f "${pkgdir}"/usr/share/glib-2.0/schemas/*.compiled
-
# Delete the gnucash-valgrind executable because the source files
# are not included with the package and the executable is hardlinked
# to the location that it was built at.