summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShyanJMC2021-06-27 19:37:49 -0300
committerShyanJMC2021-06-27 19:37:49 -0300
commita089d9ad5683ff57fa811200de66ea2518295330 (patch)
treef306201656c41caa0d9cf10b54955fa2dfa84f2b
downloadaur-a089d9ad5683ff57fa811200de66ea2518295330.tar.gz
First release.
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD58
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c817d7b3990d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gnucash-minimal
+ pkgdesc = Personal and small-business financial-accounting application. Compiled with minimal features.
+ pkgver = 4.5
+ pkgrel = 1
+ url = https://gnucash.org/
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = cmake
+ depends = boost-libs
+ depends = guile
+ depends = webkit2gtk
+ optdepends = gnucash-docs: documentation
+ optdepends = perl-date-manip: stock information lookups
+ optdepends = perl-finance-quote: stock information lookups
+ options = !emptydirs
+ source = https://razaoinfo.dl.sourceforge.net/project/gnucash/gnucash%20%28stable%29/4.5/gnucash-4.5.tar.bz2
+ sha256sums = bc1f48a8453488a2e9f6b83b68613aa55caebe4d2983460bdac7e084b46cffdc
+
+pkgname = gnucash-minimal
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..167b00c79eb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: Mark Schneider <queueRAM@gmail.com>
+
+pkgname=gnucash-minimal
+pkgver=4.5
+pkgrel=1
+pkgdesc='Personal and small-business financial-accounting application. Compiled with minimal features.'
+arch=(x86_64)
+url='https://gnucash.org/'
+license=(GPL)
+depends=(boost-libs guile webkit2gtk)
+makedepends=(boost cmake ) # gmock )
+optdepends=('gnucash-docs: documentation'
+ 'perl-date-manip: stock information lookups'
+ 'perl-finance-quote: stock information lookups')
+options=(!emptydirs)
+source=(https://razaoinfo.dl.sourceforge.net/project/gnucash/gnucash%20%28stable%29/${pkgver}/gnucash-${pkgver}.tar.bz2)
+sha256sums=('bc1f48a8453488a2e9f6b83b68613aa55caebe4d2983460bdac7e084b46cffdc')
+
+build() {
+ cd gnucash-$pkgver
+
+ # Do not treat warnings as errors
+ sed -e 's|-Werror||g' -i CMakeLists.txt
+
+ cmake -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_INSTALL_LIBDIR=/usr/lib \
+ -D WITH_PYTHON=OFF \
+ -D COMPILE_GSCHEMAS=OFF \
+ -D WITH_SQL=OFF \
+ -D WITH_AQBANKING=OFF \
+ -D WITH_GNUCASH=ON \
+ -D WITH_OFX=OFF \
+ -D ENABLE_BINRELOC=OFF \
+ -D ENABLE_REGISTER2=OFF #\
+ #-D DISABLE_DEPRECATED_GLIB=ON \
+ #-D DISABLE_DEPRECATED_GTK=ON \
+ #-D DISABLE_DEPRECATED_GNOME=ON \
+
+ make
+}
+
+check() {
+ cd gnucash-$pkgver
+ make -k check || : # 2 tests failed
+}
+
+package() {
+ cd gnucash-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ # Delete the gnucash-valgrind executable because the source files
+ # are not included with the package and the executable is hardlinked
+ # to the location that it was built at.
+ rm -f "$pkgdir/usr/bin/gnucash-valgrind"
+}