summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb3niup2015-04-04 09:00:34 +0200
committerb3niup2015-06-14 03:37:16 +0200
commit422208f527b5501ff88044b643f23a47e4effee0 (patch)
tree57cbe498144a7cf1afa9969964de19941a9a2227
parentec57c9f1485aff6cc70e51810eead5fc70963900 (diff)
downloadaur-422208f527b5501ff88044b643f23a47e4effee0.tar.gz
Updated to 2.6.6-1.
-rw-r--r--PKGBUILD11
-rw-r--r--xbt.patch31
2 files changed, 28 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c61ab36929b..4b7546bc1c13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gnucash-xbt
_pkgname=gnucash
-pkgver=2.6.5
+pkgver=2.6.6
pkgrel=1
pkgdesc="A personal and small-business financial-accounting application with Bitcoin support"
arch=('i686' 'x86_64')
@@ -11,6 +11,7 @@ license=("GPL")
depends=('slib' 'goffice0.8' 'libdbi-drivers' 'libmariadbclient' 'postgresql-libs' 'aqbanking' 'desktop-file-utils' 'webkitgtk2' 'libgnome-keyring' 'libgnomecanvas')
makedepends=('intltool')
optdepends=('evince: for print preview'
+ 'yelp: help browser'
'perl-finance-quote: for stock information lookups'
'perl-date-manip: for stock information lookups')
options=('!makeflags' '!emptydirs')
@@ -19,8 +20,8 @@ provides=('gnucash')
install=gnucash.install
source=("http://downloads.sourceforge.net/sourceforge/${_pkgname}/${_pkgname}-${pkgver}.tar.bz2"
"xbt.patch")
-sha1sums=('c9a5184603e41c6582f8342d4be9e392eceef33f'
- '3556218003a0caa823ea87c8c19e2a8e99c244d5')
+sha1sums=('7a508743047202cc4c648ff188f92741010105a1'
+ '7244b9cc71d0d03c43055c062f3eeba5e3544630')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -28,7 +29,7 @@ prepare() {
}
build() {
- cd "${srcdir}/gnucash-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
./configure --prefix=/usr --mandir=/usr/share/man --sysconfdir=/etc \
--libexecdir=/usr/lib --disable-schemas-compile --enable-ofx --enable-aqbanking
make
@@ -41,7 +42,7 @@ package() {
make DESTDIR="${pkgdir}" install-info
install -dm755 "${pkgdir}/usr/share/gconf/schemas"
- gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/gnucash.schemas" --domain gnucash "${pkgdir}"/etc/gconf/schemas/*.schemas
+ gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${_pkgname}" --domain gnucash "${pkgdir}"/etc/gconf/schemas/*.schemas
rm -f "${pkgdir}"/etc/gconf/schemas/*.schemas
# Delete the gnucash-valgrind executable because the source files
diff --git a/xbt.patch b/xbt.patch
index 757c8007b3bc..1940071f7a53 100644
--- a/xbt.patch
+++ b/xbt.patch
@@ -26,13 +26,26 @@
gnc_commodity *c = gnc_commodity_new(book,
CUR_I18N(fullname),
---- src/engine/iso-4217-currencies.scm.orig 2015-01-02 18:34:12.448355147 +0100
-+++ src/engine/iso-4217-currencies.scm 2015-01-02 18:36:30.718765059 +0100
-@@ -245,6 +245,7 @@
- ( "CFP Franc" "franc" "centime" "ISO4217" "XPF" "953" 1 100 "" ) ;; Communauté Financière du Pacifique
- ( "Code for testing purposes" "TEST" "test" "ISO4217" "XTS" "963" 1 1000000 "" ) ;; Code reserved for testing purposes
- ( "No currency" "" "" "ISO4217" "XXX" "999" 1 1000000 "" )
-+( "Bitcoin" "bitcoin" "microbitcoin" "ISO4217" "XBT" "nil" 1000000 1000000 "XBT" )
+--- src/engine/iso-4217-currencies.xml.orig 2015-04-04 08:48:15.854870167 +0200
++++ src/engine/iso-4217-currencies.xml 2015-04-04 08:48:32.791594789 +0200
+@@ -2953,6 +2953,20 @@
+ smallest-fraction="1000000"
+ local-symbol=""
+ />
++<!-- "XBT" - "Bitcoin"
++-->
++<currency
++ isocode="XBT"
++ fullname="Bitcoin"
++ unitname="bitcoin"
++ partname="microbitcoin"
++ namespace="ISO4217"
++ exchange-code="nil"
++ parts-per-unit="1000000"
++ smallest-fraction="1000000"
++ local-symbol="XBT"
++/>
++
- ;; precious metals
- ( "Silver" "ounce" "ounce" "ISO4217" "XAG" "961" 1 1000000 "" )
+ <!-- precious metals -->
+ <!-- "XAG" - "Silver"