summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb3niup2018-07-05 23:48:40 +0200
committerb3niup2018-07-05 23:48:40 +0200
commit67432f4edd9a9b804dd1933cc838bdec65c2e155 (patch)
treeaaee9caff4fac56f6fc1a591c2d3a07e3c10eb37
parentccd54dc6daec53366538ad7e3ce3e5264acb6fc2 (diff)
downloadaur-67432f4edd9a9b804dd1933cc838bdec65c2e155.tar.gz
Update to 3.2-1.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
-rw-r--r--gcc8.patch13
3 files changed, 11 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 422bf74ea4a0..b8b42161ebd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnucash-xbt
pkgdesc = A personal and small-business financial-accounting application with Bitcoin support
- pkgver = 3.1
- pkgrel = 2
+ pkgver = 3.2
+ pkgrel = 1
url = http://www.gnucash.org
arch = x86_64
license = GPL
@@ -24,14 +24,11 @@ pkgbase = gnucash-xbt
provides = gnucash
conflicts = gnucash
conflicts = gnucash-devel
- options = !makeflags
options = !emptydirs
- source = https://github.com/Gnucash/gnucash/releases/download/3.1/gnucash-3.1-1.tar.bz2
+ source = https://github.com/Gnucash/gnucash/releases/download/3.2/gnucash-3.2.tar.bz2
source = xbt.patch
- source = gcc8.patch
- sha1sums = 8ba1e61db532571e9c5423caadfbc551f6fb1b82
+ sha1sums = 4ab5baf0d7328e7b6f6a0cb0b4fea3864beb17dd
sha1sums = 52cf6820bf1dd87b5807997e49ec9c861ff516af
- sha1sums = 26704ecc0d611eff806b6bc7c3f1b632f1348980
pkgname = gnucash-xbt
diff --git a/PKGBUILD b/PKGBUILD
index 0c2817822dd4..d65ecadfd255 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=gnucash-xbt
_pkgname=gnucash
-pkgver=3.1
-pkgrel=2
-_sourcerel=-1
+pkgver=3.2
+pkgrel=1
+_sourcerel=
pkgdesc="A personal and small-business financial-accounting application with Bitcoin support"
arch=(x86_64)
url="http://www.gnucash.org"
@@ -17,20 +17,17 @@ optdepends=(
'perl-finance-quote: for stock information lookups'
'perl-date-manip: for stock information lookups'
)
-options=(!makeflags !emptydirs)
+options=(!emptydirs)
conflicts=(gnucash gnucash-devel)
provides=(gnucash)
source=("https://github.com/Gnucash/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}${_sourcerel}.tar.bz2"
- "xbt.patch"
- "gcc8.patch")
-sha1sums=('8ba1e61db532571e9c5423caadfbc551f6fb1b82'
- '52cf6820bf1dd87b5807997e49ec9c861ff516af'
- '26704ecc0d611eff806b6bc7c3f1b632f1348980')
+ "xbt.patch")
+sha1sums=('4ab5baf0d7328e7b6f6a0cb0b4fea3864beb17dd'
+ '52cf6820bf1dd87b5807997e49ec9c861ff516af')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -Np0 -i "${srcdir}/xbt.patch"
- patch -Np0 -i "${srcdir}/gcc8.patch"
cd "${srcdir}"
mkdir build
diff --git a/gcc8.patch b/gcc8.patch
deleted file mode 100644
index 064df51fc24c..000000000000
--- a/gcc8.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- CMakeLists.txt 2018-06-13 08:20:55.012756800 +0200
-+++ CMakeLists.txt 2018-06-13 08:23:34.179228185 +0200
-@@ -551,8 +551,8 @@
-
- IF (UNIX)
- SET( CMAKE_C_FLAGS "-Werror -Wdeclaration-after-statement -Wno-pointer-sign -Wall -Wmissing-prototypes -Wmissing-declarations -Wno-unused ${CMAKE_C_FLAGS}")
-- SET( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused ${CMAKE_CXX_FLAGS}")
-- SET( CMAKE_C_FLAGS "-Wno-deprecated-declarations -std=gnu11 ${CMAKE_C_FLAGS}")
-+ SET( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused -Wno-error=parentheses ${CMAKE_CXX_FLAGS}")
-+ SET( CMAKE_C_FLAGS "-Wno-deprecated-declarations -std=gnu11 -Wno-error=parentheses ${CMAKE_C_FLAGS}")
- SET( CMAKE_C_FLAGS_RELEASE "-O3 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 ${CMAKE_C_FLAGS}")
- ENDIF (UNIX)
- IF (MINGW)