summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb3niup2018-09-24 10:38:28 +0200
committerb3niup2018-09-24 10:38:28 +0200
commit9a638ac38041e9bda3b365428fe8266734ba8563 (patch)
tree136d82860e2570d2b19e5d403bb0c4147e2df18c
parentbf82474caf1ecc0ac9b265880a66cd71bfedc801 (diff)
downloadaur-9a638ac38041e9bda3b365428fe8266734ba8563.tar.gz
Fix compiler warning issues.
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-compiler-warning-issues.patch28
-rw-r--r--PKGBUILD11
3 files changed, 38 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b2605d8a280..d8902b79fe49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnucash-xbt-minimal
pkgdesc = A personal and small-business financial-accounting application with Bitcoin but without ofx/qfx import and aqbanking support
pkgver = 3.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnucash.org
arch = x86_64
license = GPL
@@ -27,8 +27,10 @@ pkgbase = gnucash-xbt-minimal
options = !emptydirs
source = https://github.com/Gnucash/gnucash/releases/download/3.2/gnucash-3.2.tar.bz2
source = xbt.patch
+ source = 0001-Fix-compiler-warning-issues.patch
sha1sums = 4ab5baf0d7328e7b6f6a0cb0b4fea3864beb17dd
sha1sums = 52cf6820bf1dd87b5807997e49ec9c861ff516af
+ sha1sums = 2a206572b385288fd4a7dd9b2bedb2b793d4ca2b
pkgname = gnucash-xbt-minimal
diff --git a/0001-Fix-compiler-warning-issues.patch b/0001-Fix-compiler-warning-issues.patch
new file mode 100644
index 000000000000..903a0b006e6c
--- /dev/null
+++ b/0001-Fix-compiler-warning-issues.patch
@@ -0,0 +1,28 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b2fcffb17..b2ecf7dc2 100644
+--- CMakeLists.txt.orig
++++ CMakeLists.txt
+@@ -572,8 +572,9 @@ set(CMAKE_CXX_FLAGS "-std=gnu++11 ${CMAKE_CXX_FLAGS}") # FIXME: should be -std=
+
+ if (UNIX)
+ set( CMAKE_C_FLAGS "-Werror -Wdeclaration-after-statement -Wno-pointer-sign -Wall -Wmissing-prototypes -Wmissing-declarations -Wno-unused ${CMAKE_C_FLAGS}")
+- set( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused -Wno-error=parentheses ${CMAKE_CXX_FLAGS}")
+ set( CMAKE_C_FLAGS "-Wno-deprecated-declarations -std=gnu11 -Wno-error=parentheses ${CMAKE_C_FLAGS}")
++ set( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused -Wno-error=parentheses ${CMAKE_CXX_FLAGS}")
++ set( CMAKE_CXX_FLAGS "-Wno-deprecated-declarations -Wno-register ${CMAKE_CXX_FLAGS}")
+ set( CMAKE_C_FLAGS_RELEASE "-O3 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 ${CMAKE_C_FLAGS}")
+ endif (UNIX)
+ if (MINGW)
+--- libgnucash/engine/CMakeLists.txt.orig
++++ libgnucash/engine/CMakeLists.txt
+@@ -235,7 +235,6 @@ add_dependencies (gncmod-engine swig-runtime-h iso-4217-c)
+ target_link_libraries(gncmod-engine gnc-core-utils gnc-module ${Boost_DATE_TIME_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${REGEX_LDFLAGS} ${GMODULE_LDFLAGS} ${GLIB2_LDFLAGS} ${GOBJECT_LDFLAGS} ${GUILE_LDFLAGS})
+
+ target_compile_definitions (gncmod-engine PRIVATE -DG_LOG_DOMAIN=\"gnc.engine\")
+-target_compile_options (gncmod-engine PRIVATE -Wno-deprecated-register)
+
+ target_include_directories (gncmod-engine
+ PRIVATE ${CMAKE_CURRENT_BINARY_DIR} # for iso-4217-currencies.c
+--
+2.19.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 7e226cb68107..2f308207ca86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gnucash-xbt-minimal
_pkgname=gnucash
pkgver=3.2
-pkgrel=1
+pkgrel=2
_sourcerel=
pkgdesc="A personal and small-business financial-accounting application with Bitcoin but without ofx/qfx import and aqbanking support"
arch=(x86_64)
@@ -21,13 +21,16 @@ options=(!emptydirs)
conflicts=(gnucash gnucash-devel gnucash-xbt)
provides=(gnucash)
source=("https://github.com/Gnucash/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}${_sourcerel}.tar.bz2"
- "xbt.patch")
+ "xbt.patch"
+ "0001-Fix-compiler-warning-issues.patch")
sha1sums=('4ab5baf0d7328e7b6f6a0cb0b4fea3864beb17dd'
- '52cf6820bf1dd87b5807997e49ec9c861ff516af')
+ '52cf6820bf1dd87b5807997e49ec9c861ff516af'
+ '2a206572b385288fd4a7dd9b2bedb2b793d4ca2b')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -Np0 -i "${srcdir}/xbt.patch"
+ patch -Np0 -i "${srcdir}/0001-Fix-compiler-warning-issues.patch"
cd "${srcdir}"
mkdir build
@@ -46,7 +49,7 @@ prepare() {
build() {
cd "${srcdir}/build"
- make -j6
+ make
}
package() {