summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb3niup2018-04-21 04:28:42 +0200
committerb3niup2018-04-21 04:28:42 +0200
commita7049e0928895f406d932258905378eb519472bc (patch)
tree23f03509a5d56c1f2f84aa86825d0b8ff6d5dad8
downloadaur-a7049e0928895f406d932258905378eb519472bc.tar.gz
Initial commit - Gnucash 3.0
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD59
-rw-r--r--xbt.patch23
4 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70cf5ea98062
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = gnucash-xbt-minimal
+ pkgdesc = A personal and small-business financial-accounting application with Bitcoin but without ofx/qfx import and aqbanking support
+ pkgver = 3.0
+ pkgrel = 1
+ url = http://www.gnucash.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = gmock
+ makedepends = cmake
+ depends = libmariadbclient
+ depends = postgresql-libs
+ depends = webkit2gtk
+ depends = boost-libs
+ depends = libsecret
+ depends = libdbi-drivers
+ optdepends = gnucash-docs: for documentation
+ optdepends = iso-codes: for translation of currency names
+ optdepends = perl-finance-quote: for stock information lookups
+ optdepends = perl-date-manip: for stock information lookups
+ provides = gnucash
+ conflicts = gnucash
+ conflicts = gnucash-devel
+ conflicts = gnucash-xbt
+ options = !makeflags
+ options = !emptydirs
+ source = https://github.com/Gnucash/gnucash/releases/download/3.0/gnucash-3.0.tar.bz2
+ source = xbt.patch
+ sha1sums = a575e853668b93b34dcd94f0ef0d1fee25b0165f
+ sha1sums = 52cf6820bf1dd87b5807997e49ec9c861ff516af
+
+pkgname = gnucash-xbt-minimal
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..967a084bc954
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+builds/
+pkg/
+src/
+gnucash-*.pkg.tar.xz
+gnucash-*.src.tar.gz
+gnucash-*.tar.bz2
+gnucash-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e3d88a293e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Benedykt 'b3niup' PrzybyƂo <b3niup@gmail.com>
+
+pkgname=gnucash-xbt-minimal
+_pkgname=gnucash
+pkgver=3.0
+pkgrel=1
+_sourcerel=
+pkgdesc="A personal and small-business financial-accounting application with Bitcoin but without ofx/qfx import and aqbanking support"
+arch=('i686' 'x86_64')
+url="http://www.gnucash.org"
+license=("GPL")
+depends=('libmariadbclient' 'postgresql-libs' 'webkit2gtk' 'boost-libs' 'libsecret' 'libdbi-drivers')
+makedepends=('boost' 'gmock' 'cmake')
+optdepends=(
+ 'gnucash-docs: for documentation'
+ 'iso-codes: for translation of currency names'
+ 'perl-finance-quote: for stock information lookups'
+ 'perl-date-manip: for stock information lookups'
+)
+options=('!makeflags' '!emptydirs')
+conflicts=('gnucash' 'gnucash-devel' 'gnucash-xbt')
+provides=('gnucash')
+source=("https://github.com/Gnucash/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}${_sourcerel}.tar.bz2"
+ "xbt.patch")
+sha1sums=('a575e853668b93b34dcd94f0ef0d1fee25b0165f'
+ '52cf6820bf1dd87b5807997e49ec9c861ff516af')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -Np0 -i "${srcdir}/xbt.patch"
+
+ cd "${srcdir}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
+ -DCOMPILE_GSCHEMAS=NO \
+ -DWITH_OFX=NO \
+ -DWITH_AQBANKING=NO \
+ "${srcdir}/${_pkgname}-${pkgver}"
+}
+
+build() {
+ cd "${srcdir}/build"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+
+ # Delete the gnucash-valgrind executable because the source files
+ # are not included with the package and the executable is hardlinked
+ # to the location that it was built at.
+ rm -f "${pkgdir}"/usr/bin/gnucash-valgrind
+
+}
diff --git a/xbt.patch b/xbt.patch
new file mode 100644
index 000000000000..7ae0788b3dea
--- /dev/null
+++ b/xbt.patch
@@ -0,0 +1,23 @@
+--- libgnucash/engine/iso-4217-currencies.xml.orig 2015-04-04 08:48:15.854870167 +0200
++++ libgnucash/engine/iso-4217-currencies.xml 2015-04-04 08:48:32.791594789 +0200
+@@ -2953,6 +2953,20 @@
+ smallest-fraction="1000000"
+ local-symbol=""
+ />
++<!-- "XBT" - "Bitcoin"
++-->
++<currency
++ isocode="XBT"
++ fullname="Bitcoin"
++ unitname="bitcoin"
++ partname="microbitcoin"
++ namespace="ISO4217"
++ exchange-code="nil"
++ parts-per-unit="1000000"
++ smallest-fraction="1000000"
++ local-symbol="XBT"
++/>
++
+
+ <!-- precious metals -->
+ <!-- "XAG" - "Silver"