summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Kasak2015-06-08 22:42:49 +0200
committerDenis Kasak2015-06-08 22:42:49 +0200
commit43eff021e2fa3383ab54040c7133970c38a41599 (patch)
treea7161927e988157912276c33c629e541b5915bc3
downloadaur-43eff021e2fa3383ab54040c7133970c38a41599.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
3 files changed, 76 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..979c9b388e68
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = gnulib-git
+ pkgdesc = GNU Portability Library
+ pkgver = v0.1.77.gd9361da
+ pkgrel = 1
+ url = http://www.gnu.org/software/gnulib
+ arch = any
+ license = custom
+ makedepends = git
+ provides = gnulib
+ conflicts = gnulib
+ source = git+git://git.sv.gnu.org/gnulib.git
+
+pkgname = gnulib-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc84ef80d3d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnulib-git
+ pkgdesc = GNU Portability Library
+ pkgver = v0.1.77.gd9361da
+ pkgrel = 1
+ url = http://www.gnu.org/software/gnulib
+ arch = any
+ license = custom
+ makedepends = git
+ provides = gnulib
+ conflicts = gnulib
+ source = git+git://git.sv.gnu.org/gnulib.git
+ md5sums = SKIP
+
+pkgname = gnulib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74d674030226
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Denis Kasak <reversed(moc.liamg@kasak.sined)>
+# Contributor: Allan McRae <allan@archlinux.org>
+
+pkgname=gnulib-git
+pkgver=v0.1.77.gd9361da
+pkgrel=1
+pkgdesc="GNU Portability Library"
+arch=('any')
+url="http://www.gnu.org/software/gnulib"
+license=('custom')
+provides=('gnulib')
+conflicts=('gnulib')
+makedepends=('git')
+source=('git+git://git.sv.gnu.org/gnulib.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$SRCDEST/gnulib"
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/gnulib"
+ sed -i "/^[ ]*gnulib_dir=/s#\`[^\`]*\`#/usr/share/$pkgname#" gnulib-tool
+ make info
+}
+
+package() {
+ cd "$srcdir/gnulib"
+ install -dm755 $pkgdir/usr/share/$pkgname
+ install -m755 -t $pkgdir/usr/share/$pkgname check-module gnulib-tool
+
+ dir=$(find build-aux lib m4 modules top -type d)
+
+ for i in $dir; do
+ install -dm755 $pkgdir/usr/share/$pkgname/$i
+ install -Dm644 -t $pkgdir/usr/share/$pkgname/$i $(find $i -maxdepth 1 -type f)
+ done
+ cp -r doc tests $pkgdir/usr/share/$pkgname/
+
+ install -dm755 $pkgdir/usr/bin
+ ln -s /usr/share/gnulib-git/gnulib-tool $pkgdir/usr/bin/
+ ln -s /usr/share/gnulib-git/check-module $pkgdir/usr/bin/
+
+ install -Dm644 doc/gnulib.info $pkgdir/usr/share/info/gnulib.info
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/${pkgname}/COPYING
+}