summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:22:26 +0200
committerStefan Husmann2015-06-09 00:22:26 +0200
commit6d5c6df54e103dbbaeffb8c1230413343e4285d7 (patch)
tree57d921ebfddcd0077382b63ca9efe261804984e4
downloadaur-6d5c6df54e103dbbaeffb8c1230413343e4285d7.tar.gz
initial version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD52
-rw-r--r--gnumeric-minimal.install13
-rw-r--r--nested_decl.patch12
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..562d0c6857aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gnumeric-minimal
+ pkgdesc = A GNOME-less spreadsheet program
+ pkgver = 1.12.21
+ pkgrel = 1
+ url = http://www.gnome.org/projects/gnumeric/
+ install = gnumeric-minimal.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = goffice-light
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ provides = gnumeric
+ conflicts = gnumeric
+ options = !makeflags
+ source = http://ftp.gnome.org/pub/gnome/sources/gnumeric/1.12/gnumeric-1.12.21.tar.xz
+ source = nested_decl.patch
+ md5sums = 393b5fc91840819522b9ba018f393e8e
+ md5sums = 4368ba37f04c0674ed3cba9a82881700
+
+pkgname = gnumeric-minimal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9645ee10aec0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: megadriver <megadriver at gmx dot com>
+# Based on gnumeric from [extra]
+
+pkgname=gnumeric-minimal
+_pkgname=gnumeric
+pkgver=1.12.21
+pkgrel=1
+pkgdesc="A GNOME-less spreadsheet program"
+arch=('i686' 'x86_64')
+url="http://www.gnome.org/projects/gnumeric/"
+license=('GPL')
+depends=('goffice-light' 'desktop-file-utils' 'hicolor-icon-theme')
+makedepends=('intltool')
+install=gnumeric-minimal.install
+conflicts=('gnumeric')
+provides=('gnumeric')
+options=('libtool')
+source=(http://ftp.gnome.org/pub/gnome/sources/${_pkgname}/${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz nested_decl.patch)
+md5sums=('393b5fc91840819522b9ba018f393e8e'
+ '4368ba37f04c0674ed3cba9a82881700')
+options=('!makeflags')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # Create a dummy file to trick gnumeric into building without docs
+ # Got this from the gnumeric SlackBuild
+ touch doc/C/gnumeric-C.omf.out
+
+ # Remove invalid mime type. (FS#26338)
+ sed -i -e 's/zz-application\/zz-winassoc-xls;//' gnumeric.desktop.in
+ sed -i 's+-Werror=implicit-function-declaration++' configure
+ sed -i 's+-Werror=nested.externs++' configure
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-schemas-install --disable-ssindex \
+ --without-gnome --without-psiconv --without-perl \
+ --without-python --without-gda
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}/etc/gconf"
+ rm -rf "${pkgdir}/usr/share/gnome"
+}
diff --git a/gnumeric-minimal.install b/gnumeric-minimal.install
new file mode 100644
index 000000000000..b9e5c6b47b6d
--- /dev/null
+++ b/gnumeric-minimal.install
@@ -0,0 +1,13 @@
+post_install() {
+ usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/nested_decl.patch b/nested_decl.patch
new file mode 100644
index 000000000000..1ae191f8e644
--- /dev/null
+++ b/nested_decl.patch
@@ -0,0 +1,12 @@
+diff -ru gnumeric-1.12.1.old/configure.ac gnumeric-1.12.1/configure.ac
+--- gnumeric-1.12.1.old/configure 2013-03-02 00:00:37.000000000 +0100
++++ gnumeric-1.12.1/configure 2013-03-09 22:03:58.000000000 +0100
+@@ -269,7 +269,7 @@
+ -Wchar-subscripts -Wwrite-strings \
+ -Wdeclaration-after-statement -Wnested-externs \
+ -Wmissing-noreturn \
+- -Werror=missing-prototypes -Werror=nested-externs \
++ -Werror=missing-prototypes \
+ -Werror=implicit-function-declaration \
+ -Wmissing-declarations -Wno-pointer-sign \
+ -Werror=format-security -Wbitwise -Wcast-to-as \