summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2014-03-10 23:48:10 +0200
committerCaleb Maclennan2014-03-10 23:48:10 +0200
commit4100e402eff7ae33636ffa5dc2d7d760b45be1f9 (patch)
treecf30b46c1d0b71aa102d96b8db0ab55f214c1256
downloadaur-4100e402eff7ae33636ffa5dc2d7d760b45be1f9.tar.gz
use lowercase per AUR specs
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42731be33eb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnumicr
+ pkgdesc = An open-source licensed Type 1 MICR E13-B font
+ pkgver = 0.30
+ pkgrel = 1
+ url = https://github.com/alerque/gnumicr
+ arch = any
+ license = GPL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/alerque/gnumicr/archive/v0.30.tar.gz
+ md5sums = 4472c31b43b332975e58e8141d56091b
+
+pkgname = gnumicr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32b0391d4958
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=gnumicr
+pkgver=0.30
+pkgrel=1
+pkgdesc="An open-source licensed Type 1 MICR E13-B font"
+arch=('any')
+url="https://github.com/alerque/gnumicr"
+license=('GPL')
+depends=('fontconfig' 'xorg-font-utils')
+source=(https://github.com/alerque/gnumicr/archive/v0.30.tar.gz)
+md5sums=('4472c31b43b332975e58e8141d56091b')
+
+post_install() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -d ${pkgdir}/usr/share/fonts/TTF
+ install -d ${pkgdir}/usr/share/fonts/Type1
+ install -d ${pkgdir}/usr/share/fonts/OTF
+
+ install -Dm644 GnuMICR.ttf "$pkgdir/usr/share/fonts/TTF/"
+ install -Dm644 GnuMICR.pfb "$pkgdir/usr/share/fonts/Type1/"
+ install -Dm644 GnuMICR.pfm "$pkgdir/usr/share/fonts/Type1/"
+ install -Dm644 GnuMICR.afm "$pkgdir/usr/share/fonts/Type1/"
+ install -Dm644 GnuMICR.otf "$pkgdir/usr/share/fonts/OTF/"
+}