summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2016-07-03 19:33:11 -0300
committerRafael Fontenelle2016-07-03 19:33:11 -0300
commit19f02a42ab0132e8f8e82ec3e9b13d2ad64938c8 (patch)
treeff0278c438f838d7883a4695b84990c4bf28e0ee
downloadaur-19f02a42ab0132e8f8e82ec3e9b13d2ad64938c8.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3da11a4a6276
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun Jul 3 22:23:08 UTC 2016
+pkgbase = gnun
+ pkgdesc = GNUnited Nations, build system for www.gnu.org translations
+ pkgver = 0.10
+ pkgrel = 1
+ url = https://www.gnu.org/software/gnun/
+ arch = any
+ license = GPL
+ depends = cvs
+ depends = subversion
+ depends = bzr
+ depends = po4a
+ depends = libxml2
+ depends = mailutils
+ depends = wdiff
+ backup = etc/gnun/gnun.conf
+ source = http://ftp.gnu.org/gnu/gnun/gnun-0.10.tar.gz
+ md5sums = eda32c542bbe1b8f6eea3e536d74e6bb
+
+pkgname = gnun
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c16cd4d2cec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+pkgname=gnun
+pkgver=0.10
+pkgrel=1
+pkgdesc="GNUnited Nations, build system for www.gnu.org translations"
+arch=(any)
+url="https://www.gnu.org/software/gnun/"
+license=('GPL')
+depends=(cvs subversion bzr po4a libxml2 mailutils wdiff)
+backup=(etc/gnun/gnun.conf)
+source=("http://ftp.gnu.org/gnu/gnun/$pkgname-$pkgver.tar.gz")
+md5sums=('eda32c542bbe1b8f6eea3e536d74e6bb')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ # gnu-mail from mailutils
+ sed -i 's/\[mail\]/[gnu-mail]/' configure.ac
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ autoreconf
+ ./configure --prefix=/usr --libexecdir=/usr/share/gnun/scripts \
+ --sysconfdir=/etc/gnun --enable-multiviews
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}