summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2021-09-18 02:35:16 +0100
committergrufo2021-09-18 02:35:16 +0100
commitf0b6bc77e78cd1fe09dbda53c1a960727e8a2028 (patch)
tree28fcfaad62f6b86cfe0b8347f3d46970e9b67fa3
parent8ef58801ee2a6fc4f63eaaaa477000603da22902 (diff)
downloadaur-f0b6bc77e78cd1fe09dbda53c1a960727e8a2028.tar.gz
Added `/etc/skel/.config/gnunet.conf`
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--gnunet-user.conf3
-rw-r--r--gnunet.install28
4 files changed, 46 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11b6326d7ebb..de9493435ed1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = gnunet-git
pkgdesc = A framework for secure peer-to-peer networking
- pkgver = 0.15.4.alpha.0.r29830.fc9ca33bc
+ pkgver = 0.15.4.alpha.0.r29840.ad9c10e6e
pkgrel = 1
url = http://gnunet.org
+ install = gnunet.install
arch = i686
arch = x86_64
license = AGPL
@@ -52,17 +53,19 @@ pkgbase = gnunet-git
conflicts = gnunet
conflicts = gnunet-bin
backup = etc/gnunet.conf
- source = git+https://gnunet.org/git/gnunet.git
+ source = git+https://git.gnunet.org/git/gnunet.git
source = gnunet-system.service
source = gnunet.sysusers
source = gnunet.tmpfiles
source = gnunet-uri.desktop
+ source = gnunet-user.conf
source = gnunet-user.service
sha256sums = SKIP
sha256sums = 163818b89beddcaf78937daba5bdf0ae060b2975de0731aa13d1ccdd813cf262
sha256sums = 66299dbbdd0219d2f5f0520e69fc094f38f789724d973c2f63a421257ea4f755
sha256sums = 5c34e1ecc6208900426f8e399e8c3edbef12cce19eba605fd7364ddb3547d9f0
sha256sums = 98e4e1d6d4fd7c7fd05d9e16402c95f1e7afeb4b97c8c68ac63e8abd11ff4ee7
+ sha256sums = 3f17b9ed2c1f8cc0f919fe477df99678c17778a31f1eeb56517e285e3cef30f2
sha256sums = 60caee20b53bcc69522556b35ac3d35d89e28c49b9a22a2ed5121df4a2c33be5
pkgname = gnunet-git
diff --git a/PKGBUILD b/PKGBUILD
index 146cb9b4dd03..a7fa65860a1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_appname='gnunet'
pkgname="${_appname}-git"
-pkgver='0.15.4.alpha.0.r29830.fc9ca33bc'
+pkgver='0.15.4.alpha.0.r29840.ad9c10e6e'
pkgrel=1
pkgdesc='A framework for secure peer-to-peer networking'
arch=('i686' 'x86_64')
@@ -36,17 +36,20 @@ optdepends=('bluez: for bluetooth transport'
'texlive-core: for generating GNS business cards via gnunet-bcd'
'zbar: for reading/writing QR codes using gnunet-qr')
backup=("etc/${_appname}.conf")
-source=("git+https://${_appname}.org/git/${_appname}.git"
+source=("git+https://git.${_appname}.org/git/${_appname}.git"
"${_appname}-system.service"
"${_appname}.sysusers"
"${_appname}.tmpfiles"
"${_appname}-uri.desktop"
+ "${_appname}-user.conf"
"${_appname}-user.service")
+install="${_appname}.install"
sha256sums=('SKIP'
'163818b89beddcaf78937daba5bdf0ae060b2975de0731aa13d1ccdd813cf262'
'66299dbbdd0219d2f5f0520e69fc094f38f789724d973c2f63a421257ea4f755'
'5c34e1ecc6208900426f8e399e8c3edbef12cce19eba605fd7364ddb3547d9f0'
'98e4e1d6d4fd7c7fd05d9e16402c95f1e7afeb4b97c8c68ac63e8abd11ff4ee7'
+ '3f17b9ed2c1f8cc0f919fe477df99678c17778a31f1eeb56517e285e3cef30f2'
'60caee20b53bcc69522556b35ac3d35d89e28c49b9a22a2ed5121df4a2c33be5')
pkgver() {
@@ -106,6 +109,11 @@ package() {
install -Dm644 "${srcdir}/${_appname}-uri.desktop" \
"${pkgdir}/usr/share/applications/${_appname}-uri.desktop"
+ install -dm755 "${pkgdir}/etc/skel/.config"
+ install -Dm644 "${srcdir}/${_appname}-user.conf" \
+ "${pkgdir}/etc/skel/.config/${_appname}.conf"
+
+
# Automatically generate a configuration file using the content of
# `/usr/share/gnunet/config.d/` as model; in this way we can ensure
# that this configuration file is the one backed up with each update,
diff --git a/gnunet-user.conf b/gnunet-user.conf
new file mode 100644
index 000000000000..22f1fe37a82d
--- /dev/null
+++ b/gnunet-user.conf
@@ -0,0 +1,3 @@
+[arm]
+START_SYSTEM_SERVICES = NO
+START_USER_SERVICES = YES
diff --git a/gnunet.install b/gnunet.install
new file mode 100644
index 000000000000..7d6a2e3ffabd
--- /dev/null
+++ b/gnunet.install
@@ -0,0 +1,28 @@
+post_install() {
+
+ local _PWD_PAIRS_="$(awk -F ':' '$3>=1000 && $3<2000 {print $1":"$6}' '/etc/passwd')"
+ local _USER_
+ local _CFG_FILE_
+
+ for _PWD_PAIR_ in ${_PWD_PAIRS_}; do
+ _USER_="$(echo $_PWD_PAIR_ | cut -d ':' -f 1)"
+ _CFG_FILE_="$(echo $_PWD_PAIR_ | cut -d ':' -f 2)/.config/gnunet.conf"
+ test -e "${_CFG_FILE_}" || install -Dm644 -o "${_USER_}" -g \
+ "$(id -gn "${_USER_}")" /etc/skel/.config/gnunet.conf \
+ "${_CFG_FILE_}"
+ done
+
+ echo
+ echo 'Do not forget to add your user to the `gnunet` group, with'
+ echo
+ echo ' sudo usermod -aG gnunet YOUR-USERNAME'
+ echo
+ echo 'If later you want to remove your user from the group, launch:'
+ echo
+ echo ' sudo gpasswd --delete YOUR-USERNAME gnunet'
+ echo
+ echo 'For information on how to use GNUnet plaese refer to the GNUnet article in the'
+ echo 'ArchWiki (https://wiki.archlinux.org/title/GNUnet).'
+ echo
+
+}