summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2020-09-22 03:35:15 +0100
committergrufo2020-09-22 03:35:15 +0100
commitf8a692935ab31a38778492fe4e873d2054f14855 (patch)
treed4c0d56168276cdaee8be0ed5a683fb9f9033d8e
parentcf8a7058cc98b0e837e8fe26c1d6c2cc77e01873 (diff)
downloadaur-f8a692935ab31a38778492fe4e873d2054f14855.tar.gz
Bump version and PKGBUILD cleaning
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD93
-rw-r--r--gnunet.install40
-rw-r--r--gnunet.sysusers3
-rw-r--r--gnunet.tmpfiles1
-rw-r--r--gnunetd.conf23
6 files changed, 79 insertions, 102 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 621597b86913..33fb9c5c8392 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,42 +1,53 @@
pkgbase = gnunet-git
pkgdesc = A framework for secure peer-to-peer networking
- pkgver = 0.12.2.r28750.b03978816
+ pkgver = 0.13.3.r29153.87467c4aa
pkgrel = 1
url = http://gnunet.org
install = gnunet.install
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL
makedepends = gettext
makedepends = pkgconfig
makedepends = autoconf
- makedepends = fakeuser-git
+ makedepends = gst-plugins-base-libs
makedepends = bluez-libs
makedepends = python
makedepends = glpk
makedepends = libpulse
+ makedepends = git
makedepends = opus
depends = gmp
depends = libgcrypt
depends = libextractor
depends = sqlite
depends = gnurl
+ depends = libsodium
depends = libmicrohttpd
depends = libunistring
depends = libidn
depends = jansson
+ depends = zbar
optdepends = bluez-libs
optdepends = python
optdepends = glpk
optdepends = libpulse
optdepends = opus
+ optdepends = gst-plugins-base-libs: for gnunet-helper-audio-record
provides = gnunet
conflicts = gnunet
options = !makeflags
backup = etc/gnunetd.conf
source = git+https://gnunet.org/git/gnunet.git
source = gnunet.service
- md5sums = SKIP
- md5sums = a64f19ce71c02c200fa78ca2d1585bc8
+ source = gnunet.sysusers
+ source = gnunet.tmpfiles
+ source = gnunetd.conf
+ sha256sums = SKIP
+ sha256sums = 2fb156b5bda51ef7c0659ca19113e7c8cd651637ffb379264e2b61f65be367d1
+ sha256sums = 65daa9fb07bdc8b8a11ca06f320b94ce6cfcc9681c6693ac655ca54881645a39
+ sha256sums = 4832e45c02ad768a713ca7f2a04b58794e268a49130b5b8ab6b91917e3d4f945
+ sha256sums = 52185d9f89eab7cdf10b8de4e5b651a854b05cc9d22e0c8139056a945b01f4cc
pkgname = gnunet-git
diff --git a/PKGBUILD b/PKGBUILD
index a235112e05f5..45485904f611 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,49 +4,40 @@
# Contributor: Sergej Pupykin <pupykin DOT s+arch AT gmail.com>
# Contributor: wahnby <wahnby AT yahoo DOT fr>
-pkgname='gnunet-git'
_appname='gnunet'
-pkgver='0.12.2.r28750.b03978816'
+pkgname="${_appname}-git"
+pkgver='0.13.3.r29153.87467c4aa'
pkgrel=1
pkgdesc="A framework for secure peer-to-peer networking"
-arch=('any')
-url="http://gnunet.org"
+arch=('i686' 'x86_64')
+url="http://${_appname}.org"
license=('GPL')
provides=("${_appname}")
conflicts=("${_appname}")
-depends=('gmp' 'libgcrypt' 'libextractor' 'sqlite' 'gnurl'
- 'libmicrohttpd' 'libunistring' 'libidn' 'jansson')
-makedepends=('gettext' 'pkgconfig' 'autoconf' 'fakeuser-git'
- 'bluez-libs' 'python' 'glpk' 'libpulse' 'opus')
+depends=('gmp' 'libgcrypt' 'libextractor' 'sqlite' 'gnurl' 'libsodium'
+ 'libmicrohttpd' 'libunistring' 'libidn' 'jansson' 'zbar')
+makedepends=('gettext' 'pkgconfig' 'autoconf' 'gst-plugins-base-libs'
+ 'bluez-libs' 'python' 'glpk' 'libpulse' 'git' 'opus')
optdepends=('bluez-libs'
'python'
'glpk'
'libpulse'
- 'opus')
-install='gnunet.install'
+ 'opus'
+ 'gst-plugins-base-libs: for gnunet-helper-audio-record')
backup=('etc/gnunetd.conf')
options=('!makeflags')
-
-source=("git+https://gnunet.org/git/${_appname}.git"
- 'gnunet.service')
-
-md5sums=('SKIP'
- 'a64f19ce71c02c200fa78ca2d1585bc8')
-
-_fakeadd_error() {
-
- echo "You must have a 'gnunet' user and group, and additionally a 'gnunetdns' group in"
- echo 'your system prior to building this package.'
- echo
- echo 'You can do:'
- echo
- echo ' groupadd -r gnunet'
- echo ' useradd -r -l -g gnunet -d /var/lib/gnunet gnunet'
- echo ' groupadd -r gnunetdns'
-
- return 1
-
-}
+install="${_appname}.install"
+source=("git+https://${_appname}.org/git/${_appname}.git"
+ "${_appname}.service"
+ "${_appname}.sysusers"
+ "${_appname}.tmpfiles"
+ 'gnunetd.conf')
+
+sha256sums=('SKIP'
+ '2fb156b5bda51ef7c0659ca19113e7c8cd651637ffb379264e2b61f65be367d1'
+ '65daa9fb07bdc8b8a11ca06f320b94ce6cfcc9681c6693ac655ca54881645a39'
+ '4832e45c02ad768a713ca7f2a04b58794e268a49130b5b8ab6b91917e3d4f945'
+ '52185d9f89eab7cdf10b8de4e5b651a854b05cc9d22e0c8139056a945b01f4cc')
pkgver() {
@@ -63,44 +54,32 @@ prepare() {
cd "${srcdir}/${_appname}"
./bootstrap
sed -i 's|contrib doc|doc|' Makefile.*
- [ -f Makefile ] || ./configure --prefix=/usr \
- --without-mysql
-
- # enable fakeadd under fakeroot environment
- export LD_PRELOAD='/usr/lib/fakeuser/libfakeuser.so'
}
-package() {
-
- local _gnunet_guid=714
- local _gnunetdns_gid=715
+build() {
cd "${srcdir}/${_appname}"
- install -dm755 "${pkgdir}/etc"
- touch "${pkgdir}/etc/gnunetd.conf"
+ test -f Makefile || ./configure --prefix=/usr --without-mysql
+ make
+ make -C contrib
- # fakeadd
- getent group gnunet > /dev/null || fakeadd -G -n gnunet -g ${_gnunet_guid} || _fakeadd_error
- getent passwd gnunet > /dev/null || fakeadd -U -n gnunet -u ${_gnunet_guid} -g ${_gnunet_guid} -d /var/lib/gnunet || _fakeadd_error
- getent group gnunetdns > /dev/null || fakeadd -G -n gnunetdns -g ${_gnunetdns_gid} || _fakeadd_error
- install -dm755 "${pkgdir}/var/lib/gnunet"
- chown gnunet:gnunet "${pkgdir}/var/lib/gnunet"
+}
- if ! getent group gnunet > /dev/null || ! getent passwd gnunet > /dev/null || ! getent group gnunetdns > /dev/null || [[ $(stat -c %u "${pkgdir}/var/lib/gnunet") -ne ${_gnunet_guid} ]]; then
- _fakeadd_error
- fi
+package() {
- # build
- # ...I know, `make` should be inside `build()`... But we need the power of fakeadd+fakeroot *while* building!
- make
- make -C contrib
+ cd "${srcdir}/${_appname}"
+
+ install -dm755 "${pkgdir}/etc"
+ install -Dm644 "${srcdir}/gnunetd.conf" "${pkgdir}/etc/gnunetd.conf"
- # install
make DESTDIR="${pkgdir}" install
make DESTDIR="${pkgdir}" -C contrib install
- install -Dm0644 "${srcdir}/${_appname}.service" "${pkgdir}/usr/lib/systemd/system/${_appname}.service"
+
+ install -Dm644 "${srcdir}/${_appname}.service" "${pkgdir}/usr/lib/systemd/system/${_appname}.service"
+ install -Dm644 "${srcdir}/${_appname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${_appname}.conf"
+ install -Dm644 "${srcdir}/${_appname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${_appname}.conf"
}
diff --git a/gnunet.install b/gnunet.install
index 563eb7d91a76..6ee826d70508 100644
--- a/gnunet.install
+++ b/gnunet.install
@@ -1,45 +1,5 @@
-# Please, synch these two variables with the ones with the same name in PKGBUILD
-_gnunet_guid=714
-_gnunetdns_gid=715
-
-post_install() {
-
- if ! getent passwd gnunet > /dev/null; then
-
- if ! getent group gnunet > /dev/null; then
-
- echo "Creating group 'gnunet'..."
- groupadd gnunet -g ${_gnunet_guid}
-
- fi
-
- echo "Creating user 'gnunet'..."
- useradd -r -l -u ${_gnunet_guid} -g ${_gnunet_guid} -d /var/lib/gnunet gnunet
-
- fi
-
- chown gnunet:gnunet '/var/lib/gnunet'
-
- if ! getent group gnunetdns > /dev/null; then
-
- echo "Creating group 'gnunetdns'..."
- groupadd gnunetdns -g ${_gnunetdns_gid}
-
- fi
-
-}
-
post_remove() {
-
getent passwd gnunet > /dev/null && userdel gnunet
getent group gnunet > /dev/null && groupdel gnunet
getent group gnunetdns > /dev/null && groupdel gnunetdns
-
-}
-
-post_upgrade() {
-
- post_install
-
}
-
diff --git a/gnunet.sysusers b/gnunet.sysusers
new file mode 100644
index 000000000000..718bcfac1eb8
--- /dev/null
+++ b/gnunet.sysusers
@@ -0,0 +1,3 @@
+g gnunet -
+u gnunet - "GNUnet" /var/lib/gnunet
+g gnunetdns -
diff --git a/gnunet.tmpfiles b/gnunet.tmpfiles
new file mode 100644
index 000000000000..981e940f256b
--- /dev/null
+++ b/gnunet.tmpfiles
@@ -0,0 +1 @@
+Z /var/lib/gnunet - gnunet gnunet - -
diff --git a/gnunetd.conf b/gnunetd.conf
new file mode 100644
index 000000000000..b356a9bdaff0
--- /dev/null
+++ b/gnunetd.conf
@@ -0,0 +1,23 @@
+[hostlist]
+OPTIONS = -b
+SERVERS = http://v9.gnunet.org:58080/
+
+[arm]
+DEFAULTSERVICES = topology hostlist fs
+
+[nat]
+BEHIND_NAT = YES
+ENABLE_UPNP = YES
+DISABLEV6 = YES
+
+[PATHS]
+DEFAULTCONFIG = /etc/gnunetd.conf
+LIBEXECDIR = /usr/lib/gnunet/libexec/
+DOCDIR = /usr/share/doc/gnunet/
+ICONDIR = /usr/share/icons/
+LOCALEDIR = /usr/share/locale/
+PREFIX = /usr/
+BINDIR = /usr/bin/
+LIBDIR = /usr/lib/gnunet/
+DATADIR = /usr/share/gnunet/
+