summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 18:57:14 +0000
committerAntonio Rojas2020-05-01 18:57:14 +0000
commit62b74207e5828a4763e57986b873eb64180aa26f (patch)
treec413ba3e43132bc5ab95954f3daedc7ac142f629
downloadaur-62b74207e5828a4763e57986b873eb64180aa26f.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f942be15166
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnunet-gtk
+ pkgdesc = A frontend for GNUnet
+ pkgver = 0.12.0
+ pkgrel = 1
+ url = https://gnunet.org
+ arch = x86_64
+ license = GPL
+ depends = gnunet
+ depends = glade
+ depends = adns
+ source = https://ftp.gnu.org/gnu/gnunet/gnunet-gtk-0.12.0.tar.gz
+ sha256sums = cb99da11d68107f9709ee5be49cc574e9a03054767334767930ae6b0bd1a4421
+
+pkgname = gnunet-gtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52d20835fcf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: wahnby <wahnby@yahoo.fr>
+
+pkgname=gnunet-gtk
+pkgver=0.12.0
+pkgrel=1
+pkgdesc="A frontend for GNUnet"
+arch=('x86_64')
+url="https://gnunet.org"
+license=('GPL')
+depends=('gnunet' 'glade' 'adns')
+source=(https://ftp.gnu.org/gnu/gnunet/$pkgname-$pkgver.tar.gz)
+sha256sums=('cb99da11d68107f9709ee5be49cc574e9a03054767334767930ae6b0bd1a4421')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ sed -i 's|CC -E|CC -O2 -E|g' configure
+ ./configure --prefix=/usr --with-gnunet=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}