summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMeno Abels2016-12-14 18:33:10 +0100
committerMeno Abels2016-12-14 18:33:10 +0100
commit8a882849b1d610475a8844b9fd3e7873dd655fc4 (patch)
treee8c6f8554f5c21df78eb2c6c671ec25fe6770f67
parentddaf79c7e19b75869baa8282538fcf6a558acbf6 (diff)
downloadaur-8a882849b1d610475a8844b9fd3e7873dd655fc4.tar.gz
* fixes
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 8 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82d00f134dab..bd62030e4622 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,13 +28,6 @@ pkgbase = gnupg-clavator
depends = readline
depends = pinentry
provides = gnupg=2.1.16-quick-keytocard
- provides = dirmngr
- conflicts = gnupg2
- conflicts = gnupg
- conflicts = dirmngr
- replaces = gnupg2
- replaces = gnupg
- replaces = dirmngr
source = git://github.com/mabels/gnupg.git
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f5fdbd3f9f48..edc220705bc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_gitname=gnupg
pkgname=gnupg-clavator
-pkgver=2.1.16+clavator
+pkgver=15a2d9a
pkgrel=1
pkgdesc="GNU Privacy Guard 2 - a PGP replacement tool. Development version. Do not use in production environments. Test new ECC algorithms by using \"gpg --full-gen-key --expert\""
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -14,8 +14,8 @@ depends=('libldap' 'curl' 'bzip2' 'zlib' 'libksba>=1.2' 'libgpg-error' 'libgcryp
license=('GPL')
url="http://www.gnupg.org/"
makedepends=('git' 'ghostscript' 'transfig' 'automake')
-provides=("gnupg=${pkgver}" 'dirmngr')
-conflicts=('gnupg2' 'gnupg' 'dirmngr')
+#provides=("gnupg=${pkgver}" 'dirmngr')
+#conflicts=('gnupg2' 'gnupg' 'dirmngr')
install=${pkgname}.install
source=("git://github.com/mabels/gnupg.git#branch=quick-keytocard")
sha1sums=('SKIP')
@@ -29,13 +29,13 @@ pkgver() {
build() {
cd "$_gitname"
+ echo "2.1-clavator" > VERSION
./autogen.sh --force
-
+ echo "2.1-clavator" > VERSION
./configure \
--enable-maintainer-mode \
- --prefix=/usr \
- --libexecdir=/usr/lib/gnupg
-
+ --prefix=/usr/local
+ echo "2.1-clavator" > VERSION
make
}
@@ -43,7 +43,7 @@ package() {
cd "$_gitname"
make DESTDIR=${pkgdir} install
- ln -s gpg2 "$pkgdir/usr/bin/gpg"
+#ln -s gpg2 "$pkgdir/usr/bin/gpg"
}
# vim: ft=sh syn=sh et sw=2