summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphazo2013-06-30 21:24:22 +0200
committerAlphazo2015-06-10 16:13:57 +0200
commit8c81b5d27d57a03a4a8acd2d7fa0b0d6b36d085d (patch)
tree450ec088486543ee18f103fd9c08bb71c0de919b
downloadaur-8c81b5d27d57a03a4a8acd2d7fa0b0d6b36d085d.tar.gz
Initial import to AUR4
-rw-r--r--.SRCINFO40
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD50
-rw-r--r--gnupg-git.install21
4 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87953cebe2b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = gnupg-git
+ pkgdesc = GNU Privacy Guard 2 - a PGP replacement tool. Development version. Do not use in production environments. Test new ECC algorithm by using --expert with --gen-key
+ pkgver = 2.1.0beta3+220+g82c25e6
+ pkgrel = 1
+ url = http://www.gnupg.org/
+ install = gnupg-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = ghostscript
+ makedepends = transfig
+ makedepends = automake-1.11
+ depends = libldap
+ depends = curl
+ depends = bzip2
+ depends = zlib
+ depends = libksba>=1.2
+ depends = libgpg-error>=1.1
+ depends = libgcrypt>=1.5
+ depends = pth
+ depends = libusb-compat
+ depends = libassuan-git
+ depends = npth-git
+ depends = texinfo
+ depends = readline
+ depends = pinentry
+ provides = gnupg=2.1.0beta3+220+g82c25e6
+ provides = dirmngr
+ conflicts = gnupg2
+ conflicts = gnupg
+ conflicts = dirmngr
+ replaces = gnupg2
+ replaces = gnupg
+ replaces = dirmngr
+ source = git://git.gnupg.org/gnupg.git
+ sha1sums = SKIP
+
+pkgname = gnupg-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5714c070958e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+gnupg/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8289ee279caa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# GnuPG2 GIT version
+# Contributor: alphazo@gmail.com
+# Based on official package maintained by Tobias Powalowski <tpowa@archlinux.org>
+# Cleanup from @holos
+
+_gitname=gnupg
+pkgname=gnupg-git
+pkgver=2.1.0beta3+220+g82c25e6
+pkgrel=1
+pkgdesc="GNU Privacy Guard 2 - a PGP replacement tool. Development version. Do not use in production environments. Test new ECC algorithm by using --expert with --gen-key"
+arch=('i686' 'x86_64')
+depends=('libldap' 'curl' 'bzip2' 'zlib' 'libksba>=1.2' 'libgpg-error>=1.1' 'libgcrypt>=1.5'
+ 'pth' 'libusb-compat' 'libassuan-git' 'npth-git' 'texinfo' 'readline' 'pinentry')
+license=('GPL')
+url="http://www.gnupg.org/"
+makedepends=('git' 'ghostscript' 'transfig' 'automake-1.11')
+provides=("gnupg=${pkgver}" 'dirmngr')
+conflicts=('gnupg2' 'gnupg' 'dirmngr')
+replaces=('gnupg2' 'gnupg' 'dirmngr')
+install=${pkgname}.install
+source=("git://git.gnupg.org/gnupg.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+
+ git describe --tags | sed 's/gnupg-//;s/-/+/g'
+}
+
+build() {
+ cd "$_gitname"
+
+ AUTOMAKE_SUFFIX="-1.11" ./autogen.sh --force
+
+ ./configure \
+ --enable-maintainer-mode \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/gnupg
+
+ make
+}
+
+package() {
+ cd "$_gitname"
+
+ make DESTDIR=${pkgdir} install
+ ln -s gpg2 "$pkgdir/usr/bin/gpg"
+}
+
+# vim: ft=sh syn=sh et sw=2
diff --git a/gnupg-git.install b/gnupg-git.install
new file mode 100644
index 000000000000..9f3cfc6a441e
--- /dev/null
+++ b/gnupg-git.install
@@ -0,0 +1,21 @@
+info_dir=/usr/share/info
+info_files=(gnupg.info gnupg.info-1 gnupg.info-2)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for f in ${info_files[@]}; do
+ usr/bin/install-info ${info_dir}/$f ${info_dir}/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for f in ${info_files[@]}; do
+ usr/bin/install-info --delete ${info_dir}/$f ${info_dir}/dir 2> /dev/null
+ done
+}
+