summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-12-26 15:34:47 -0500
committerVincent Grande2020-12-26 15:34:47 -0500
commit9b895c4b494d1afeb82f03c6ceb21c6e3dae7cf0 (patch)
treea45978f91a6abaff977e151a953e5b275370394f
downloadaur-9b895c4b494d1afeb82f03c6ceb21c6e3dae7cf0.tar.gz
initial upload
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD86
-rw-r--r--drop-import-clean.patch52
-rw-r--r--gnupg-git.install31
4 files changed, 204 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..156db98dc67a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = gnupg-minimal-git
+ pkgdesc = Complete and free implementation of the OpenPGP standard
+ pkgver = 2.2.7+1227+gf9bbc7516
+ pkgrel = 1
+ url = https://www.gnupg.org/
+ install = gnupg-git.install
+ arch = x86_64
+ license = GPL
+ checkdepends = openssh
+ makedepends = git
+ depends = npth
+ depends = libgpg-error
+ depends = libgcrypt
+ depends = libksba
+ depends = libassuan
+ depends = pinentry
+ depends = bzip2
+ depends = readline
+ depends = libreadline.so
+ depends = gnutls
+ depends = sqlite
+ depends = zlib
+ depends = glibc
+ optdepends = libldap: gpg2keys_ldap
+ optdepends = libusb-compat: scdaemon
+ optdepends = pcsclite: scdaemon
+ provides = gnupg=2.2
+ conflicts = gnupg
+ source = git://git.gnupg.org/gnupg.git
+ source = drop-import-clean.patch
+ sha256sums = SKIP
+ sha256sums = 7ae777b0f4c6d3301768149f66f1d5b723841f3a4a2f0d4c601a0b2114bb7fe1
+
+pkgname = gnupg-minimal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdccc81bac9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,86 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Stephanie Wilde-Hobbs <git@stephanie.is>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: alphazo@gmail.com
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+# Contributor: @holos
+
+_pkgname=gnupg
+pkgname=${_pkgname}-minimal-git
+pkgver=2.2.7+1227+gf9bbc7516
+pkgrel=1
+pkgdesc='Complete and free implementation of the OpenPGP standard'
+url='https://www.gnupg.org/'
+license=('GPL')
+arch=('x86_64')
+conflicts=(${_pkgname})
+provides=(${_pkgname}=2.2)
+checkdepends=('openssh')
+makedepends=('git')
+depends=('npth' 'libgpg-error' 'libgcrypt' 'libksba' 'libassuan'
+ 'pinentry' 'bzip2' 'readline' 'libreadline.so' 'gnutls'
+ 'sqlite' 'zlib' 'glibc')
+optdepends=('libldap: gpg2keys_ldap'
+ 'libusb-compat: scdaemon'
+ 'pcsclite: scdaemon')
+source=("git://git.gnupg.org/gnupg.git"
+ 'drop-import-clean.patch')
+sha256sums=('SKIP'
+ '7ae777b0f4c6d3301768149f66f1d5b723841f3a4a2f0d4c601a0b2114bb7fe1')
+install=gnupg-git.install
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags | sed 's/gnupg-//;s/-/+/g'
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 -i ../drop-import-clean.patch
+
+ ./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/gnupg \
+ --enable-maintainer-mode \
+ --enable-symcryptrun \
+ --disable-selinux-support \
+ --disable-photo-viewers \
+ --without-photo-viewer \
+ --disable-card-support \
+ --disable-ccid-driver \
+ --disable-npth-debug \
+ --disable-ldap \
+ --without-mailprog \
+ --disable-log-clock \
+
+
+ make
+}
+
+# check() {
+# cd "${srcdir}/${_pkgname}"
+# make check
+# }
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+ ln -s gpg "${pkgdir}"/usr/bin/gpg2
+ ln -s gpgv "${pkgdir}"/usr/bin/gpgv2
+
+ install -Dm 644 doc/examples/systemd-user/*.* -t "${pkgdir}/usr/lib/systemd/user"
+}
+
+# vim: ts=2 sw=2 noet:
diff --git a/drop-import-clean.patch b/drop-import-clean.patch
new file mode 100644
index 000000000000..9c42fece93ad
--- /dev/null
+++ b/drop-import-clean.patch
@@ -0,0 +1,52 @@
+From 1690a464b28fa24ce82189a9bf5d7ce9b44804b8 Mon Sep 17 00:00:00 2001
+From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+Date: Mon, 15 Jul 2019 16:24:35 -0400
+Subject: [PATCH 3/7] gpg: drop import-clean from default keyserver import
+ options
+
+* g10/gpg.c (main): drop IMPORT_CLEAN from the
+default opt.keyserver_options.import_options
+* doc/gpg.texi: reflect this change in the documentation
+
+Given that SELF_SIGS_ONLY is already set, it's not clear what
+additional benefit IMPORT_CLEAN provides. Furthermore, IMPORT_CLEAN
+means that receiving an OpenPGP certificate from a keyserver will
+potentially delete data that is otherwise held in the local keyring,
+which is surprising to users who expect retrieval from the keyservers
+to be purely additive.
+
+GnuPG-Bug-Id: 4628
+Signed-off-by: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+---
+ doc/gpg.texi | 2 +-
+ g10/gpg.c | 3 +--
+ 2 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/doc/gpg.texi b/doc/gpg.texi
+index 4870441d4..551459a74 100644
+--- a/doc/gpg.texi
++++ b/doc/gpg.texi
+@@ -1963,7 +1963,7 @@ are available for all keyserver types, some common options are:
+
+ @end table
+
+-The default list of options is: "self-sigs-only, import-clean,
++The default list of options is: "self-sigs-only,
+ repair-keys, repair-pks-subkey-bug, export-attributes,
+ honor-pka-record".
+
+diff --git a/g10/gpg.c b/g10/gpg.c
+index 68cc22041..fa2bcfa5e 100644
+--- a/g10/gpg.c
++++ b/g10/gpg.c
+@@ -2407,6 +2407,5 @@ main (int argc, char **argv)
+ | IMPORT_SELF_SIGS_ONLY
+ | IMPORT_COLLAPSE_UIDS
+- | IMPORT_COLLAPSE_SUBKEYS
+- | IMPORT_CLEAN);
++ | IMPORT_COLLAPSE_SUBKEYS);
+ opt.keyserver_options.export_options = EXPORT_ATTRIBUTES;
+ opt.keyserver_options.options = KEYSERVER_HONOR_PKA_RECORD;
+--
+2.27.0
+
diff --git a/gnupg-git.install b/gnupg-git.install
new file mode 100644
index 000000000000..1f19b99feb2d
--- /dev/null
+++ b/gnupg-git.install
@@ -0,0 +1,31 @@
+_global_units() {
+ _units=(dirmngr.socket gpg-agent.socket gpg-agent-{browser,extra,ssh}.socket)
+ _dir=/etc/systemd/user/sockets.target.wants
+
+ case $1 in
+ enable)
+ mkdir -p $_dir
+ for _u in "${_units[@]}"; do
+ ln -sf /usr/lib/systemd/user/$_u $_dir/$_u
+ done
+ ;;
+ disable)
+ for _u in "${_units[@]}"; do
+ rm -f $_dir/$_u
+ done
+ rmdir -p --ignore-fail-on-non-empty $_dir
+ ;;
+ esac
+}
+
+post_install() {
+ # See FS#42798 and FS#47371
+ dirmngr </dev/null &>/dev/null
+
+ # Let systemd supervise daemons by default
+ _global_units enable
+}
+
+pre_remove() {
+ _global_units disable
+}