summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNimrod Maclomhair2017-04-23 01:40:38 +0200
committerNimrod Maclomhair2017-04-23 01:40:38 +0200
commit411f1c6459ee8b1bed5aa0909d88b5ea31c02f98 (patch)
tree90e7cd6a560cd6dd51a6696c21f54a6fe0dfce97
downloadaur-411f1c6459ee8b1bed5aa0909d88b5ea31c02f98.tar.gz
So headless gnuplot is coming.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD71
-rw-r--r--lua53_compat.patch13
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41a119064edd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gnuplot-headless
+ pkgdesc = Plotting package which outputs to PostScript, PNG, GIF, and others, without any X or latex depencies.
+ pkgver = 5.0.6
+ pkgrel = 1
+ url = http://www.gnuplot.info
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = readline
+ depends = lua
+ depends = ncurses
+ provides = gnuplot
+ conflicts = gnuplot
+ options = !makeflags
+ source = http://downloads.sourceforge.net/sourceforge/gnuplot/gnuplot-5.0.6.tar.gz
+ source = lua53_compat.patch
+ sha1sums = f7b8948166b22e5bd658d5cf7579716f4821dba0
+ sha1sums = 9005fa9e4da91ceedb8ccd1d761866e7b064f8b1
+
+pkgname = gnuplot-headless
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b7dd480824a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Nimrod Maclomhair <nimrod4garoa@gmail.com>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=gnuplot-headless
+pkgver=5.0.6
+pkgrel=1
+pkgdesc="Plotting package which outputs to PostScript, PNG, GIF, and others, without any X or latex depencies."
+arch=('i686' 'x86_64')
+url="http://www.gnuplot.info"
+license=('custom')
+depends=('readline' 'lua' 'ncurses')
+makedepends=()
+provides=('gnuplot')
+conflicts=('gnuplot')
+options=('!makeflags')
+source=("http://downloads.sourceforge.net/sourceforge/gnuplot/gnuplot-$pkgver.tar.gz"
+ "lua53_compat.patch")
+sha1sums=('f7b8948166b22e5bd658d5cf7579716f4821dba0'
+ '9005fa9e4da91ceedb8ccd1d761866e7b064f8b1')
+
+prepare() {
+ cd "${srcdir}/gnuplot-${pkgver}"
+
+ # fix default source location; use the GDFONTPATH variable to modify at runtime
+ sed -i 's|/usr/X11R6/lib/X11/fonts/truetype|/usr/share/fonts/TTF|' src/variable.c
+
+ sed -i -e 's|/usr/X11R6/lib/X11/fonts/Type1|/usr/share/fonts/Type1|' \
+ -e 's|$(X11ROOT)/X11R6/lib/X11/fonts/Type1|$(X11ROOT)/usr/share/fonts/Type1|' \
+ src/variable.c
+
+ patch -p1 < "$srcdir"/lua53_compat.patch
+}
+
+build() {
+ cd "${srcdir}/gnuplot-${pkgver}"
+
+ # If you want png and jpeg terminal support, set --with-gd and get
+ # add "gd-headless" as an depency.
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/bin \
+ --with-gihdir=/usr/share/gnuplot \
+ --with-readline=gnu \
+ --disable-x11-mbfonts \
+ --disable-x11-external \
+ --disable-wxwidgets \
+ --without-latex \
+ --without-cairo \
+ --with-qt=no \
+ --without-libcerf \
+ --disable-raise-console \
+ --with-x=no \
+ --with-aquaterm=no \
+ --with-linux-vga=no \
+ --with-ggi=no \
+ --with-gd=no
+
+# --with-bitmap-terminals \
+
+ make pkglibexecdir=/usr/bin
+}
+
+package() {
+ cd "${srcdir}/gnuplot-${pkgver}"
+ make pkglibexecdir=/usr/bin DESTDIR="${pkgdir}" install
+
+ install -Dm644 Copyright "${pkgdir}/usr/share/licenses/$pkgname/Copyright"
+
+ rm -f "${pkgdir}/usr/share/texmf-dist/ls-R"
+}
diff --git a/lua53_compat.patch b/lua53_compat.patch
new file mode 100644
index 000000000000..9d3be770ae02
--- /dev/null
+++ b/lua53_compat.patch
@@ -0,0 +1,13 @@
+diff --git a/term/lua.trm b/term/lua.trm
+index af63d68..474221f 100644
+--- a/term/lua.trm
++++ b/term/lua.trm
+@@ -110,6 +110,8 @@ TERM_PUBLIC void LUA_boxed_text __PROTO((unsigned int, unsigned int, int));
+ # define LUA_EXTERNAL_IMAGES 1
+ #endif
+
++
++#define LUA_COMPAT_APIINTCASTS
+ #include <lua.h>
+ #include <lualib.h>
+ #include <lauxlib.h>