summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Ermakov2015-10-30 21:19:11 +0300
committerAlexey Ermakov2015-10-30 21:19:11 +0300
commit54845ba71f32b180456a1be7ae3a6780ab97d3d5 (patch)
tree5461a74c157c8d82f5b9a2a41758e2f275f289f1
downloadaur-54845ba71f32b180456a1be7ae3a6780ab97d3d5.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--gnupod.install15
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f83a442b768
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gnupod-git
+ pkgdesc = GNUpod is a collection of tools which allow you to use your iPod under GNU/Linux and other UNIX-like operating systems.
+ pkgver = 520.a3f4c9c
+ pkgrel = 1
+ url = https://github.com/richvdh/gnupod
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = perl-digest-sha1
+ depends = perl-xml-parser
+ depends = perl-unicode-string
+ depends = perl-mp3-info
+ depends = perl-date-parse
+ depends = perl-text-charwidth
+ source = git+https://github.com/richvdh/gnupod.git
+ md5sums = SKIP
+
+pkgname = gnupod-git
+ install = gnupod.install
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0c739b6faf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alexey Ermakov <fufler[at]gmail[dot]com>
+
+pkgname=gnupod-git
+_pkgname=gnupod
+pkgver=520.a3f4c9c
+pkgrel=1
+pkgdesc="GNUpod is a collection of tools which allow you to use your iPod under GNU/Linux and other UNIX-like operating systems."
+arch=('any')
+url="https://github.com/richvdh/gnupod"
+license=('GPL3')
+depends=('perl-digest-sha1' 'perl-xml-parser' 'perl-unicode-string' 'perl-mp3-info' 'perl-date-parse' 'perl-text-charwidth')
+makedepends=('git')
+source=("git+https://github.com/richvdh/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ autoconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ install=gnupod.install
+
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
diff --git a/gnupod.install b/gnupod.install
new file mode 100644
index 000000000000..3921ac9cd298
--- /dev/null
+++ b/gnupod.install
@@ -0,0 +1,15 @@
+infodir=usr/share/info
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ install-info $infodir/gnupod.info.gz $infodir/dir 2> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ install-info --delete $infodir/gnupod.info.gz $infodir/dir 2> /dev/null
+}