summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrnmst/Franco2015-08-25 22:49:28 +0200
committerfrnmst/Franco2015-08-25 22:49:28 +0200
commit3906cd39778ed11fe8287126abdf4523fe78de6c (patch)
tree202f64ebff9663df0a3fbb92d44e52ce6daf92cb
downloadaur-3906cd39778ed11fe8287126abdf4523fe78de6c.tar.gz
Initial import.
-rw-r--r--.INSTALL3
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD46
3 files changed, 75 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..3c280dd443b5
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,3 @@
+post_install() {
+ echo "To setup GNUpot: gnupot -n"
+}
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a627a9e8f810
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gnupot
+ pkgdesc = Yet another libre Dropbox clone written in bash and based on git.
+ pkgver = 0.1.r0.gec65a2e
+ pkgrel = 1
+ url = https://github.com/frnmst/gnupot
+ install = .INSTALL
+ arch = any
+ license = GPL3
+ makedepends = coreutils
+ makedepends = sed
+ makedepends = git>=2.4
+ depends = coreutils
+ depends = bash
+ depends = openssh
+ depends = inotify-tools
+ depends = util-linux
+ depends = libnotify
+ depends = git>=2.4
+ depends = dialog
+ depends = glibc
+ depends = trickle
+ source = git://github.com/frnmst/gnupot.git
+ md5sums = SKIP
+
+pkgname = gnupot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a3c2b6036dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Franco Masotti <franco dot masotti at student dot unife dot it>
+pkgname=gnupot
+pkgver=0.1.r0.gec65a2e
+pkgrel=1
+pkgdesc="Yet another libre Dropbox clone written in bash and based on git."
+arch=('any')
+url="https://github.com/frnmst/gnupot"
+license=('GPL3')
+depends=('coreutils'
+ 'bash'
+ 'openssh'
+ 'inotify-tools'
+ 'util-linux'
+ 'libnotify'
+ 'git>=2.4'
+ 'dialog'
+ 'glibc'
+ 'trickle')
+makedepends=('coreutils' 'sed' 'git>=2.4')
+install=.INSTALL
+source=(git://github.com/frnmst/gnupot.git)
+md5sums=('SKIP')
+
+build() {
+ # Changes local to global paths.
+ cd "$srcdir"/"$pkgname"/src
+ sed -i 's/"${0%\/gnupot}"/\/opt\/gnupot/' gnupot.sh functions.sh
+ sed -i 's/src\/configVariables.conf/\/opt\/gnupot\/src\/configVariables.conf/' config.sh
+}
+
+pkgver () {
+ cd "$srcdir"/"$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir"/"$pkgname"
+ install -Dm755 src/gnupot.sh "$pkgdir"/opt/gnupot/src/gnupot.sh
+ install -Dm766 src/functions.sh "$pkgdir"/opt/gnupot/src/functions.sh
+ install -Dm755 src/config.sh "$pkgdir"/opt/gnupot/src/config.sh
+ install -Dm766 src/configVariables.conf "$pkgdir"/opt/gnupot/src/configVariables.conf
+ install -Dm755 man/gnupot.man "$pkgdir"/usr/share/man/man1/gnupot.1
+ install -Dm755 man/gnupot.config.man "$pkgdir"/usr/share/man/man5/gnupot.config.5
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s /opt/gnupot/src/gnupot.sh "$pkgdir"/usr/bin/gnupot
+}