summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrnmst/Franco Masotti2016-01-26 20:34:56 +0100
committerfrnmst/Franco Masotti2016-01-26 20:34:56 +0100
commit412319e487d533ba460b207eb94f1eb29b35ff7f (patch)
tree63d2148830b51a5845a20cc8c85427a7866958ab
parent79f13daa777c8541d9ca2960b807ff0eb3835e8f (diff)
downloadaur-412319e487d533ba460b207eb94f1eb29b35ff7f.tar.gz
Updated to 0.4.
-rw-r--r--.INSTALL2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
3 files changed, 14 insertions, 8 deletions
diff --git a/.INSTALL b/.INSTALL
index b8c895b6766e..7a71d81139e2 100644
--- a/.INSTALL
+++ b/.INSTALL
@@ -1,7 +1,9 @@
post_install() {
echo "To setup GNUpot: gnupot -n"
+ echo "For more information, visit the wiki at https://github.com/frnmst/gnupot/wiki"
}
post_upgrade() {
echo "To update GNUpot you must run the setup again with: gnupot -n"
+ echo "For more information, visit the wiki at https://github.com/frnmst/gnupot/wiki"
}
diff --git a/.SRCINFO b/.SRCINFO
index d9fc2c82d836..d798621c58f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 19:29:12 UTC 2016
pkgbase = gnupot
- pkgdesc = Yet another libre Dropbox clone written in bash and based on git.
- pkgver = 0.3.r0.ge7a03b7
- pkgrel = 3
+ pkgdesc = A fully free, highly customizable and very efficient shell wrapper for git and SSH, which imitates Dropbox.
+ pkgver = 0.4.r0.g2e04d10
+ pkgrel = 1
url = https://github.com/frnmst/gnupot
install = .INSTALL
arch = any
@@ -20,7 +22,7 @@ pkgbase = gnupot
depends = glibc
depends = trickle
depends = gawk
- source = git://github.com/frnmst/gnupot.git
+ source = git://github.com/frnmst/gnupot.git#branch=master
md5sums = SKIP
pkgname = gnupot
diff --git a/PKGBUILD b/PKGBUILD
index 60269d39f0bc..416334da7581 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Franco Masotti <franco dot masotti at student dot unife dot it>
pkgname=gnupot
-pkgver=0.3.r0.ge7a03b7
-pkgrel=3
-pkgdesc="Yet another libre Dropbox clone written in bash and based on git."
+pkgver=0.4.r0.g2e04d10
+pkgrel=1
+pkgdesc="A fully free, highly customizable and very efficient shell wrapper for git and SSH, which imitates Dropbox."
arch=('any')
url="https://github.com/frnmst/gnupot"
license=('GPL3')
@@ -19,7 +19,7 @@ depends=('coreutils'
'gawk')
makedepends=('coreutils' 'sed' 'git>=2.4')
install=.INSTALL
-source=(git://github.com/frnmst/gnupot.git)
+source=('git://github.com/frnmst/gnupot.git#branch=master')
md5sums=('SKIP')
build() {
@@ -28,6 +28,7 @@ build() {
sed -i 's/"${0%\/gnupot}"/\/opt\/gnupot/' gnupot.sh
sed -i 's/"${prgPath%\/gnupot}"/\/opt\/gnupot/' functions.sh
sed -i "s/git describe --long/printf \""$pkgver\\\\n"\"/" functions.sh
+ sed -i 's/src\/form.sh/\/opt\/gnupot\/src\/form.sh/' config.sh
sed -i 's/src\/configVariables.conf/\/opt\/gnupot\/src\/configVariables.conf/' config.sh
}
@@ -41,6 +42,7 @@ package() {
install -Dm755 src/gnupot.sh "$pkgdir"/opt/gnupot/src/gnupot.sh
install -Dm766 src/functions.sh "$pkgdir"/opt/gnupot/src/functions.sh
install -Dm755 src/config.sh "$pkgdir"/opt/gnupot/src/config.sh
+ install -Dm766 src/form.sh "$pkgdir"/opt/gnupot/src/form.sh
install -Dm766 src/configVariables.conf "$pkgdir"/opt/gnupot/src/configVariables.conf
install -Dm755 man/gnupot.man "$pkgdir"/usr/share/man/man1/gnupot.1
install -Dm755 man/gnupot.config.man "$pkgdir"/usr/share/man/man5/gnupot.config.5