summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrnmst/Franco2015-10-09 17:47:03 +0200
committerfrnmst/Franco2015-10-09 17:47:03 +0200
commit5ed8312af7d8e96f9b69d6d1f8349ace0bc230b4 (patch)
tree244c7232838f2f0aec8f77b28077e815d9ab8cb4
parent3906cd39778ed11fe8287126abdf4523fe78de6c (diff)
downloadaur-5ed8312af7d8e96f9b69d6d1f8349ace0bc230b4.tar.gz
Updated to 0.2.
-rw-r--r--.INSTALL4
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
3 files changed, 10 insertions, 3 deletions
diff --git a/.INSTALL b/.INSTALL
index 3c280dd443b5..b8c895b6766e 100644
--- a/.INSTALL
+++ b/.INSTALL
@@ -1,3 +1,7 @@
post_install() {
echo "To setup GNUpot: gnupot -n"
}
+
+post_upgrade() {
+ echo "To update GNUpot you must run the setup again with: gnupot -n"
+}
diff --git a/.SRCINFO b/.SRCINFO
index a627a9e8f810..2e7e168c74fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnupot
pkgdesc = Yet another libre Dropbox clone written in bash and based on git.
- pkgver = 0.1.r0.gec65a2e
+ pkgver = 0.2.r0.gb1f3a5b
pkgrel = 1
url = https://github.com/frnmst/gnupot
install = .INSTALL
@@ -19,6 +19,7 @@ pkgbase = gnupot
depends = dialog
depends = glibc
depends = trickle
+ depends = gawk
source = git://github.com/frnmst/gnupot.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0a3c2b6036dd..3b94e7bf7620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Franco Masotti <franco dot masotti at student dot unife dot it>
pkgname=gnupot
-pkgver=0.1.r0.gec65a2e
+pkgver=0.2.r0.gb1f3a5b
pkgrel=1
pkgdesc="Yet another libre Dropbox clone written in bash and based on git."
arch=('any')
@@ -15,7 +15,8 @@ depends=('coreutils'
'git>=2.4'
'dialog'
'glibc'
- 'trickle')
+ 'trickle'
+ 'gawk')
makedepends=('coreutils' 'sed' 'git>=2.4')
install=.INSTALL
source=(git://github.com/frnmst/gnupot.git)
@@ -25,6 +26,7 @@ build() {
# Changes local to global paths.
cd "$srcdir"/"$pkgname"/src
sed -i 's/"${0%\/gnupot}"/\/opt\/gnupot/' gnupot.sh functions.sh
+ sed -i "s/git describe --long/printf \""$pkgver\\\\n"\"/" functions.sh
sed -i 's/src\/configVariables.conf/\/opt\/gnupot\/src\/configVariables.conf/' config.sh
}