summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergely Imreh2017-04-03 10:48:44 +0100
committerGergely Imreh2017-04-03 10:48:44 +0100
commit9a709bb734ed1e08aadff3c9a6b27eaa8686fca7 (patch)
treef29d31f6d08370da692d5917515a7b1edce8d2e4
downloadaur-9a709bb734ed1e08aadff3c9a6b27eaa8686fca7.tar.gz
gnushogi 1.4.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..911b425d1078
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Apr 3 09:12:37 UTC 2017
+pkgbase = gnushogi
+ pkgdesc = A computer program that plays the game of Shogi, also known as Japanese Chess.
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = https://www.gnu.org/software/gnushogi/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = autoconf
+ makedepends = gcc
+ source = http://ftp.gnu.org/gnu/gnushogi/gnushogi-1.4.2.tar.gz
+ sha256sums = 1ecc48a866303c63652552b325d685e7ef5e9893244080291a61d96505d52b29
+
+pkgname = gnushogi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02048f2d4176
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=gnushogi
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="A computer program that plays the game of Shogi, also known as Japanese Chess."
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/gnushogi/"
+license=('GPL')
+makedepends=('autoconf' 'gcc')
+source=("http://ftp.gnu.org/gnu/gnushogi/gnushogi-${pkgver}.tar.gz")
+sha256sums=('1ecc48a866303c63652552b325d685e7ef5e9893244080291a61d96505d52b29')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make prefix="${pkgdir}/usr/" install
+}