summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2016-07-16 09:30:07 -0400
committerStorm Dragon2016-07-16 09:30:07 -0400
commit1070cc6d938de731e6d85bb5b5ac850d5f4f598b (patch)
tree588be7fddaa68a5629a03d514886e5cadd296a4e
downloadaur-1070cc6d938de731e6d85bb5b5ac850d5f4f598b.tar.gz
GnuSocialShell-git initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab5f3b549843
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jul 16 13:29:54 UTC 2016
+pkgbase = gnusocialshell-git
+ pkgdesc = A simple useful text-based GnuSocial client to UNIX-like Operating Systems
+ pkgver = .
+ pkgrel = 1
+ url = https://github.com/dalmemail/GnuSocialShell
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = curl
+ provides = gss
+ conflicts = gss
+ source = git+https://github.com/dalmemail/GnuSocialShell.git
+ md5sums = SKIP
+
+pkgname = gnusocialshell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28a54aae13fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+_pkgname="GnuSocialShell"
+pkgname="gnusocialshell-git"
+pkgver=.
+pkgrel=1
+pkgdesc="A simple useful text-based GnuSocial client to UNIX-like Operating Systems"
+arch=('armv7h' 'i686' 'x86_64')
+url="https://github.com/dalmemail/GnuSocialShell"
+license=("GPL")
+depends=("curl")
+makedepends=("git")
+provides=("gss")
+conflicts=("gss")
+source=("git+${url}.git")
+md5sums=("SKIP")
+
+pkgver()
+{
+ cd "$_pkgname"
+ git shortlog | tail -n2 | tr -Cd "[:digit:].-"
+}
+
+build()
+{
+ cd "$_pkgname"
+ make
+}
+
+package()
+{
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: