summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2016-11-14 14:12:48 -0500
committerStorm Dragon2016-11-14 14:12:48 -0500
commit5226e0a5b2bf271587213543ef10c4e3cb69fd17 (patch)
treea2a1012b784d6619542de94d4bf99e8cfc0f87c3
parent1070cc6d938de731e6d85bb5b5ac850d5f4f598b (diff)
downloadaur-5226e0a5b2bf271587213543ef10c4e3cb69fd17.tar.gz
Updated PKGBUILD to work with new compilation methods.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab5f3b549843..30a9c0555d35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jul 16 13:29:54 UTC 2016
+# Mon Nov 14 19:12:32 UTC 2016
pkgbase = gnusocialshell-git
pkgdesc = A simple useful text-based GnuSocial client to UNIX-like Operating Systems
- pkgver = .
- pkgrel = 1
+ pkgver = 0.2
+ pkgrel = 2
url = https://github.com/dalmemail/GnuSocialShell
arch = armv7h
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 28a54aae13fc..813305460093 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
_pkgname="GnuSocialShell"
pkgname="gnusocialshell-git"
-pkgver=.
-pkgrel=1
+pkgver=0.2
+pkgrel=2
pkgdesc="A simple useful text-based GnuSocial client to UNIX-like Operating Systems"
arch=('armv7h' 'i686' 'x86_64')
url="https://github.com/dalmemail/GnuSocialShell"
@@ -14,15 +14,14 @@ conflicts=("gss")
source=("git+${url}.git")
md5sums=("SKIP")
-pkgver()
-{
- cd "$_pkgname"
- git shortlog | tail -n2 | tr -Cd "[:digit:].-"
-}
-
+# Needs a pkgver function but none of the ones I try work, there are no tags and the tagless code only generates a . which causes an error.
+
build()
{
cd "$_pkgname"
+ touch config.rpath
+ autoreconf -iv
+ ./configure --prefix=/usr/local
make
}