summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-25 17:39:28 +0800
committerChocobo12017-08-25 20:41:02 +0800
commite6146e0f11ff417d037e2c571ad8eb98a77cb065 (patch)
tree46e4c3d30caccfd7e419130239a12ff796d28b9d
downloadaur-e6146e0f11ff417d037e2c571ad8eb98a77cb065.tar.gz
newpkg: gnutls-git 3.6.0.1.r11.g2b29963b5-1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD45
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21cfe50d3ba0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = gnutls-git
+ pkgdesc = Provides useful functions commonly found on BSD systems
+ pkgver = 3.6.0.1.r11.g2b29963b5
+ pkgrel = 1
+ url = https://www.gnutls.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ depends = libidn2
+ depends = libtasn1
+ depends = libunistring
+ depends = nettle
+ depends = p11-kit
+ depends = readline
+ depends = zlib
+ optdepends = guile: for use with Guile bindings
+ provides = gnutls
+ conflicts = gnutls
+ source = git+https://gitlab.com/gnutls/gnutls.git
+ sha256sums = SKIP
+
+pkgname = gnutls-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfe821aeda77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gnutls-git
+pkgver=3.6.0.1.r11.g2b29963b5
+pkgrel=1
+pkgdesc="Provides useful functions commonly found on BSD systems"
+arch=('i686' 'x86_64')
+url="https://www.gnutls.org/"
+license=('LGPL')
+depends=('glibc' 'libidn2' 'libtasn1' 'libunistring' 'nettle' 'p11-kit' 'readline' 'zlib')
+optdepends=('guile: for use with Guile bindings')
+makedepends=('git')
+provides=('gnutls')
+conflicts=('gnutls')
+source=("git+https://gitlab.com/gnutls/gnutls.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "gnutls"
+
+ git describe --long --tags | sed 's/^gnutls_//;s/\([^-]*-g\)/r\1/;s/[_-]/./g'
+}
+
+build() {
+ cd "gnutls"
+
+ make autoreconf
+ ./configure --prefix="/usr" \
+ --with-default-trust-store-pkcs11="pkcs11:model=p11-kit-trust;manufacturer=PKCS%2311%20Kit" \
+ --enable-guile --with-guile-site-dir=no
+ make
+}
+
+check() {
+ cd "gnutls"
+
+ #make check
+}
+
+package() {
+ cd "gnutls"
+
+ make DESTDIR="$pkgdir" install
+}