summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoron Behar2019-05-12 08:32:23 +0200
committerDoron Behar2019-05-12 08:32:23 +0200
commit81426ae171e5d95b53a154646198b825f51631b0 (patch)
tree3693fa0bbfea7988564102c6e995d8becd41c16e
downloadaur-81426ae171e5d95b53a154646198b825f51631b0.tar.gz
Add files from upstream
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD48
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a058d1578ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gnutls
+ pkgdesc = A library which provides a secure layer over a reliable transport layer
+ pkgver = 3.6.7
+ pkgrel = 1
+ url = https://www.gnutls.org/
+ arch = x86_64
+ license = GPL3
+ license = LGPL2.1
+ checkdepends = net-tools
+ depends = gcc-libs
+ depends = libtasn1
+ depends = readline
+ depends = zlib
+ depends = nettle
+ depends = p11-kit
+ depends = libidn2
+ depends = libidn2.so
+ depends = libunistring
+ options = !zipman
+ source = https://www.gnupg.org/ftp/gcrypt/gnutls/v3.6/gnutls-3.6.7.tar.xz
+ source = https://www.gnupg.org/ftp/gcrypt/gnutls/v3.6/gnutls-3.6.7.tar.xz.sig
+ validpgpkeys = 0424D4EE81A0E3D119C6F835EDA21E94B565716F
+ validpgpkeys = 1F42418905D8206AA754CCDC29EE58B996865171
+ sha256sums = 5b3409ad5aaf239808730d1ee12fdcd148c0be00262c7edf157af655a8a188e2
+ sha256sums = SKIP
+
+pkgname = gnutls
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12c8974e03e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=gnutls
+pkgver=3.6.7
+pkgrel=1
+pkgdesc="A library which provides a secure layer over a reliable transport layer"
+arch=('x86_64')
+license=('GPL3' 'LGPL2.1')
+url="https://www.gnutls.org/"
+options=('!zipman')
+depends=('gcc-libs' 'libtasn1' 'readline' 'zlib' 'nettle' 'p11-kit' 'libidn2'
+ 'libidn2.so' 'libunistring')
+checkdepends=('net-tools')
+source=(https://www.gnupg.org/ftp/gcrypt/gnutls/v3.6/${pkgname}-${pkgver}.tar.xz{,.sig})
+sha256sums=('5b3409ad5aaf239808730d1ee12fdcd148c0be00262c7edf157af655a8a188e2'
+ 'SKIP')
+validpgpkeys=('0424D4EE81A0E3D119C6F835EDA21E94B565716F'
+ '1F42418905D8206AA754CCDC29EE58B996865171')
+ # "Simon Josefsson <simon@josefsson.org>"
+ # "Nikos Mavrogiannopoulos <nmav@gnutls.org>
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --with-zlib \
+ --disable-static \
+ --with-idn \
+ --disable-guile \
+ --with-default-trust-store-pkcs11="pkcs11:model=p11-kit-trust;manufacturer=PKCS%2311%20Kit"
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+check() {
+ cd ${pkgname}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ # lots of .png files are put into infodir and are gzipped by makepkg! this needs to be fixed by using !zipman
+ # gzip -9 all files in infodir and manpages manually
+ find "$pkgdir/usr/share/info" -name '*.info*' -exec gzip -9 {} \;
+ find "$pkgdir/usr/share/man" -exec gzip -9 {} \;
+}