summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-09 17:09:51 -0500
committerVincent Grande2021-01-09 17:09:51 -0500
commit11c8116664939c626c3438d6cb32843faf2c9865 (patch)
tree8c0366720334b5f4c60b2d39a0ba92f3fa5effd8
downloadaur-11c8116664939c626c3438d6cb32843faf2c9865.tar.gz
initial upload
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD43
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb72fc547493
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gnutls-nodocs-git
+ pkgdesc = A secure communications library implementing the SSL, TLS and DTLS protocols and technologies around them
+ pkgver = 3.6.13.r104.g52e78f1e3
+ pkgrel = 1
+ url = https://www.gnutls.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = autogen
+ makedepends = gperf
+ makedepends = rsync
+ makedepends = wget
+ depends = glibc
+ depends = libidn2
+ depends = libtasn1
+ depends = libunistring
+ depends = nettle
+ depends = p11-kit
+ depends = readline
+ depends = zlib
+ provides = gnutls
+ conflicts = gnutls
+ source = git+https://gitlab.com/gnutls/gnutls.git
+ sha256sums = SKIP
+
+pkgname = gnutls-nodocs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec9a3b8bb4c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gnutls-nodocs-git
+pkgver=3.6.13.r104.g52e78f1e3
+pkgrel=1
+pkgdesc="A secure communications library implementing the SSL, TLS and DTLS protocols and technologies around them"
+arch=('i686' 'x86_64')
+url="https://www.gnutls.org/"
+license=('LGPL')
+depends=('glibc' 'libidn2' 'libtasn1' 'libunistring' 'nettle' 'p11-kit' 'readline' 'zlib')
+makedepends=('git' 'autogen' 'gperf' 'rsync' 'wget')
+provides=('gnutls')
+conflicts=('gnutls')
+source=("git+https://gitlab.com/gnutls/gnutls.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "gnutls"
+
+ git describe --long --tags | sed 's/^gnutls_//;s/\([^-]*-g\)/r\1/;s/[_-]/./g'
+}
+
+build() {
+ cd "gnutls"
+
+ ./bootstrap --skip-po
+ ./configure \
+ --prefix="/usr" \
+ --with-default-trust-store-pkcs11="pkcs11:model=p11-kit-trust;manufacturer=PKCS%2311%20Kit" \
+ --disable-full-test-suite \
+ --disable-guile\
+ --disable-doc \
+ --disable-manpages
+ make
+}
+
+package() {
+ cd "gnutls"
+
+ make DESTDIR="$pkgdir" install
+}