summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadoslaw Chmielarz2015-09-26 19:49:58 +0200
committerRadoslaw Chmielarz2015-09-26 19:49:58 +0200
commit56786232c9f9d730b2f51eef958aef622a9e51e5 (patch)
tree0397941b4177ee64c7f9316667d9e40758d5996b
downloadaur-56786232c9f9d730b2f51eef958aef622a9e51e5.tar.gz
First release of gnutls with OpenSSL compatiblity mode turned on
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD28
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46f21b1ff37f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by makepkg 4.2.1
+# Sat Sep 26 17:44:10 UTC 2015
+pkgbase = gnutls-openssl
+ pkgdesc = Secure communications library with OpenSSL
+ pkgver = 3.4.5
+ pkgrel = 1
+ url = http://gnutls.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libidn
+ depends = libtasn1
+ depends = nettle
+ depends = gc
+ optdepends = zlib: for compression
+ optdepends = p11-kit: for PKCS #11 support
+ optdepends = guile: for use with Guile bindings
+ optdepends = unbound: for DNSSEC/DANE functionality
+ provides = gnutls
+ conflicts = gnutls
+ source = ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4/gnutls-3.4.5.tar.xz
+ sha256sums = af88b8e0460728d034ff3f454f7851a09b7f0959a93531b6f8d35658ef0f7aae
+
+pkgname = gnutls-openssl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..607d75d84517
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Radoslaw Chmielarz <radoslaw.chmielarz@gmail.com>
+pkgname=gnutls-openssl
+pkgver=3.4.5
+pkgrel=1
+pkgdesc="Secure communications library with OpenSSL"
+arch=("i686" "x86_64")
+url="http://gnutls.org/"
+license=('GPL')
+depends=("libidn" "libtasn1" "nettle" "gc")
+optdepends=("zlib: for compression"
+ "p11-kit: for PKCS #11 support"
+ "guile: for use with Guile bindings"
+ "unbound: for DNSSEC/DANE functionality")
+provides=("gnutls")
+conflicts=("gnutls")
+source=("ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4/gnutls-${pkgver}.tar.xz")
+sha256sums=('af88b8e0460728d034ff3f454f7851a09b7f0959a93531b6f8d35658ef0f7aae')
+build() {
+ cd gnutls-${pkgver}
+
+ ./configure --prefix=/usr --enable-openssl-compatibility
+ make
+}
+package() {
+ cd gnutls-${pkgver}
+
+ make DESTDIR=${pkgdir} install
+}