summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarshit Shah2018-02-10 20:10:30 +0100
committerDarshit Shah2018-02-10 23:20:37 +0100
commit6f161f85d8b3f6f5f7807b27fa0b0c5e89470ee7 (patch)
tree5035684dc9a511a393ada8c46417fb95c908dcf2
downloadaur-gnutls-tiny-git.tar.gz
Smaller, simpler gnutls
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD57
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ace86691c615
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gnutls-tiny-git
+ pkgdesc = A secure communications library implementing the SSL, TLS and DTLS protocols and technologies around them
+ pkgver = 3.6.0.1.r11.g2b29963b5
+ pkgrel = 1
+ url = https://www.gnutls.org/
+ arch = x86_64
+ license = GPL3
+ license = LGPL2.1
+ checkdepends = net-tools
+ makedepends = git
+ depends = gcc-libs
+ depends = libidn2
+ depends = libtasn1
+ depends = libunistring
+ depends = nettle
+ depends = p11-kit
+ depends = readline
+ depends = zlib
+ optdepends = guile: for use with Guile bindings
+ provides = gnutls
+ conflicts = gnutls
+ source = git+https://gitlab.com/gnutls/gnutls.git
+ sha256sums = SKIP
+
+pkgname = gnutls-tiny-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..224fddc55be4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Darshit Shah <darnir gnu org>
+# Contributor: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gnutls-tiny-git
+pkgver=3.6.0.1.r11.g2b29963b5
+pkgrel=1
+pkgdesc="A secure communications library implementing the SSL, TLS and DTLS protocols and technologies around them"
+arch=('x86_64')
+url="https://www.gnutls.org/"
+license=('GPL3' 'LGPL2.1')
+depends=('gcc-libs' 'libidn2' 'libtasn1' 'libunistring' 'nettle' 'p11-kit' 'readline' 'zlib')
+checkdepends=('net-tools')
+optdepends=('guile: for use with Guile bindings')
+makedepends=('git')
+provides=('gnutls')
+conflicts=('gnutls')
+source=("git+https://gitlab.com/gnutls/gnutls.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "gnutls"
+
+ make bootstrap
+}
+
+pkgver() {
+ cd "gnutls"
+
+ git describe --long --tags | sed 's/^gnutls_//;s/\([^-]*-g\)/r\1/;s/[_-]/./g'
+}
+
+build() {
+ cd "gnutls"
+
+ ./configure --prefix=/usr \
+ --with-zlib \
+ --disable-static \
+ --enable-guile --with-guile-site-dir=no \
+ --disable-tests \
+ --disable-tools \
+ --disable-maintainer-mode \
+ --disable-libdane \
+ --disable-doc \
+ --with-default-trust-store-pkcs11="pkcs11:model=p11-kit-trust;manufacturer=PKCS%2311%20Kit"
+ make
+}
+
+package() {
+ cd "gnutls"
+
+ make DESTDIR="$pkgdir" install
+
+ # lots of .png files are put into infodir and are gzipped by makepkg! this needs to be fixed by using !zipman
+ # gzip -9 all files in infodir and manpages manually
+ find "$pkgdir/usr/share/info" -name '*.info*' -exec gzip -9 {} \;
+ find "$pkgdir/usr/share/man" -exec gzip -9 {} \;
+}