summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Ziemba2016-04-23 18:37:16 -0400
committerDan Ziemba2016-04-23 18:37:16 -0400
commit93d750d65e3da24a527bb6c91aad0718c644cf3c (patch)
tree94cda5b0f50004de55028c476286c8f08ee5a5c4
parentb840db14cf35bb4ca0b1d3fc3e4d92205a4c0f97 (diff)
downloadaur-93d750d65e3da24a527bb6c91aad0718c644cf3c.tar.gz
Patch to fix OCSP test.
https://gitlab.com/gnutls/gnutls/issues/85
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--fix-ocsp-test.patch41
3 files changed, 58 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29524a84d066..c694d9583bde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Apr 10 22:57:15 UTC 2016
+# Sat Apr 23 22:36:49 UTC 2016
pkgbase = gnutls28
pkgdesc = A library which provides a secure layer over a reliable transport layer (legacy version)
pkgver = 3.3.22
- pkgrel = 2
+ pkgrel = 3
url = http://gnutls.org/
arch = i686
arch = x86_64
@@ -18,8 +18,10 @@ pkgbase = gnutls28
conflicts = libgnutls28
source = ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/gnutls-3.3.22.tar.xz
source = ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/gnutls-3.3.22.tar.xz.sig
+ source = fix-ocsp-test.patch
sha256sums = 0ffa233e022e851f3f5f7811ac9223081a0870d5a05a7cf35a9f22e173c7b009
sha256sums = SKIP
+ sha256sums = 1cd916ca3e6b8261df8d1869138aa0b15fe700d650020fd914980e96dafb6dc4
pkgname = gnutls28
diff --git a/PKGBUILD b/PKGBUILD
index b5cf2ce5ef53..f64568943ad2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgbasename=gnutls
pkgname=${_pkgbasename}28
pkgver=3.3.22
-pkgrel=2
+pkgrel=3
pkgdesc="A library which provides a secure layer over a reliable transport layer (legacy version)"
arch=('i686' 'x86_64')
license=('GPL3' 'LGPL2.1')
@@ -17,11 +17,21 @@ url="http://gnutls.org/"
depends=('zlib' 'nettle' 'p11-kit' 'libtasn1' 'libidn')
provides=('libgnutls28')
conflicts=('libgnutls28')
-source=(ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/${_pkgbasename}-${pkgver}.tar.xz{,.sig})
+_downloadUrl="ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/${_pkgbasename}-${pkgver}.tar.xz"
+source=("${_downloadUrl}"
+ "${_downloadUrl}.sig"
+ 'fix-ocsp-test.patch')
sha256sums=('0ffa233e022e851f3f5f7811ac9223081a0870d5a05a7cf35a9f22e173c7b009'
- 'SKIP')
+ 'SKIP'
+ '1cd916ca3e6b8261df8d1869138aa0b15fe700d650020fd914980e96dafb6dc4')
validpgpkeys=(1F42418905D8206AA754CCDC29EE58B996865171)
+prepare() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+
+ patch -p1 -i "${srcdir}/fix-ocsp-test.patch"
+}
+
build() {
cd "${srcdir}/${_pkgbasename}-${pkgver}"
diff --git a/fix-ocsp-test.patch b/fix-ocsp-test.patch
new file mode 100644
index 000000000000..8e22b8ad22f6
--- /dev/null
+++ b/fix-ocsp-test.patch
@@ -0,0 +1,41 @@
+From f7ce0134742f496a20aaf53ac4c6b77ea6ae1d7d Mon Sep 17 00:00:00 2001
+From: Nikos Mavrogiannopoulos <nmav@redhat.com>
+Date: Fri, 8 Apr 2016 13:36:44 +0200
+Subject: [PATCH] pkix.asn: corrected byKey definition
+
+OCSP is defined in an EXPLICIT tags module, and as such
+we must tag explicitly all of its tags.
+---
+ lib/pkix.asn | 2 +-
+ lib/pkix_asn1_tab.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lib/pkix.asn b/lib/pkix.asn
+index aa0c574..9657bde 100644
+--- a/lib/pkix.asn
++++ b/lib/pkix.asn
+@@ -620,7 +620,7 @@ ResponseData ::= SEQUENCE {
+ ResponderID ::= CHOICE {
+ -- Changed to work with the libtasn1 parser.
+ byName [1] EXPLICIT RDNSequence, --Name
+- byKey [2] OCTET STRING --SHA-1 hash of responder's public key
++ byKey [2] EXPLICIT OCTET STRING --SHA-1 hash of responder's public key
+ }
+
+ SingleResponse ::= SEQUENCE {
+diff --git a/lib/pkix_asn1_tab.c b/lib/pkix_asn1_tab.c
+index 60dba18..cc26868 100644
+--- a/lib/pkix_asn1_tab.c
++++ b/lib/pkix_asn1_tab.c
+@@ -467,7 +467,7 @@ const asn1_static_node pkix_asn1_tab[] = {
+ { "byName", 1610620930, "RDNSequence"},
+ { NULL, 2056, "1"},
+ { "byKey", 536879111, NULL },
+- { NULL, 4104, "2"},
++ { NULL, 2056, "2"},
+ { "SingleResponse", 1610612741, NULL },
+ { "certID", 1073741826, "CertID"},
+ { "certStatus", 1073741826, "CertStatus"},
+--
+libgit2 0.24.0
+