summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornolash2020-12-07 21:11:10 +0100
committernolash2020-12-07 21:11:57 +0100
commitde45ce60a7097f37066d401ec21961b7bc33a5be (patch)
tree5e2c5ea28c5dca886dff54a6b268b40802ff198a
downloadaur-de45ce60a7097f37066d401ec21961b7bc33a5be.tar.gz
Initial commit, v0.4.0
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD51
-rw-r--r--bee.install21
-rw-r--r--bee.install.sigbin0 -> 566 bytes
-rw-r--r--bee.service15
-rw-r--r--bee.service.sigbin0 -> 566 bytes
-rw-r--r--bee.yaml67
-rw-r--r--bee.yaml.sigbin0 -> 566 bytes
8 files changed, 186 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e24bf9092f52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = go-bee
+ pkgdesc = Censorship resistant storage and communication infrastructure for a truly sovereign digital society
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://swarm-gateways.net/bzz:/docs.swarm.eth/
+ install = bee.install
+ arch = x86_64
+ groups = eth-swarm
+ license = BSD
+ makedepends = go>=1.15.0
+ makedepends = git
+ optdepends = go-ethereum
+ optdepends = systemd
+ provides = go-bee
+ source = git+https://github.com/ethersphere/bee#commit=625d64e656241a058678e310ba7b02e40f3ec50d
+ source = bee.yaml
+ source = bee.service
+ source = bee.install
+ source = bee.yaml.sig
+ source = bee.service.sig
+ source = bee.install.sig
+ validpgpkeys = 0826EDA1702D1E87C6E2875121D2E7BB88C2A746
+ sha256sums = SKIP
+ sha256sums = 8841026f29b181f0582c6e7e08c28e472f073cf5f42f729abc5bf696802a08ae
+ sha256sums = 04a72c89f76b4649046c9a588216657803a5a6a29f3c22484bf11dd8639be2b4
+ sha256sums = 3158225705621a572fadfc9c552e748fec338535eb29923af558669c549329db
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = go-bee
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f2a599a4b8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Louis Holbrook <dev@holbrook.no>
+pkgname=go-bee
+pkgver=0.4.0
+pkgrel=1
+epoch=
+pkgdesc="Censorship resistant storage and communication infrastructure for a truly sovereign digital society"
+arch=('x86_64')
+url="https://swarm-gateways.net/bzz:/docs.swarm.eth/"
+license=('BSD')
+groups=(eth-swarm)
+depends=()
+makedepends=('go>=1.15.0' 'git')
+checkdepends=()
+optdepends=('go-ethereum' 'systemd')
+provides=('go-bee')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=bee.install
+source=("git+https://github.com/ethersphere/bee#commit=625d64e656241a058678e310ba7b02e40f3ec50d" "bee.yaml" "bee.service" "bee.install" "bee.yaml.sig" "bee.service.sig" "bee.install.sig")
+noextract=()
+sha256sums=("SKIP" "8841026f29b181f0582c6e7e08c28e472f073cf5f42f729abc5bf696802a08ae" "04a72c89f76b4649046c9a588216657803a5a6a29f3c22484bf11dd8639be2b4" "3158225705621a572fadfc9c552e748fec338535eb29923af558669c549329db" "SKIP" "SKIP" "SKIP")
+validpgpkeys=("0826EDA1702D1E87C6E2875121D2E7BB88C2A746")
+
+build() {
+ msg "Building the bee binaries"
+ msg2 "using gopath $GOPATH"
+ pushd bee
+
+ # makepkg seems to set LDFLAGS, and they break the build
+ _LDFLAGS=$LDFLAGS
+ unset LDFLAGS
+ make binaries
+ LDFLAGS=$_LDFLAGS
+}
+
+package() {
+ pushd bee
+ install -v -D -m0755 dist/bee ${pkgdir}/usr/bin/bee
+ install -v -D -m0755 dist/bee-split ${pkgdir}/usr/bin/bee-split
+ install -v -D -m0755 dist/bee-join ${pkgdir}/usr/bin/bee-join
+ install -v -D -m0755 dist/bee-file ${pkgdir}/usr/bin/bee-file
+
+ #install -v -d -m0755 ${pkgdir}/usr/share/licenses/bee
+ install -v -D -m0644 LICENSE ${pkgdir}/usr/share/licenses/bee/LICENSE
+ popd
+ install -v -D -m0644 bee.yaml ${pkgdir}/etc/bee/bee.yml
+ install -v -D -m0644 bee.service ${pkgdir}/usr/lib/systemd/system/bee.service
+}
+
diff --git a/bee.install b/bee.install
new file mode 100644
index 000000000000..b7cbe2b22908
--- /dev/null
+++ b/bee.install
@@ -0,0 +1,21 @@
+post_install () {
+ if [[ -z $(getent passwd bzz) ]]; then
+ echo "creating bzz user"
+ useradd -r -s /usr/bin/nologin -d /var/lib/bee
+ else
+ echo "already have bzz user"
+ fi
+ if [ ! -d /var/lib/bee ]; then
+ mkdir -vp /var/lib/bee
+ chown -R bzz:bzz /var/lib/bee
+ fi
+ if [ ! -f /var/lib/bee/password ]; then
+ dd status=none if=/dev/urandom count=1 | tr -dc A-Za-z0-9 | head -c 20 > /var/lib/bee/password
+ chown -v bzz:bzz /var/lib/bee/password
+ chmod -v 400 /var/lib/bee/password
+ echo "generated new password in /var/lib/bee/password"
+ fi
+ echo -e "\e[0;93mSwap is disabled by default in this configuation."
+ echo -e "\e[0;93mTo use swap you need an Ethereum endpoint."
+ echo -e "\e[0m"
+}
diff --git a/bee.install.sig b/bee.install.sig
new file mode 100644
index 000000000000..5779129497ec
--- /dev/null
+++ b/bee.install.sig
Binary files differ
diff --git a/bee.service b/bee.service
new file mode 100644
index 000000000000..c40995edc650
--- /dev/null
+++ b/bee.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Bee - Ethereum Swarm node
+Documentation=https://swarm-gateways.net/bzz:/docs.swarm.eth/
+After=network.target
+
+[Service]
+Environment="BEE_CONFIG=/etc/bee/bee.yml"
+User=bzz
+Group=bzz
+ExecStart=/usr/bin/bee start --config ${BEE_CONFIG}
+RestartSec=1
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/bee.service.sig b/bee.service.sig
new file mode 100644
index 000000000000..b8d5ebf6a35c
--- /dev/null
+++ b/bee.service.sig
Binary files differ
diff --git a/bee.yaml b/bee.yaml
new file mode 100644
index 000000000000..0eb7afd44700
--- /dev/null
+++ b/bee.yaml
@@ -0,0 +1,67 @@
+## Bee configuration - https://swarm-gateways.net/bzz:/docs.swarm.eth/docs/installation/configuration
+
+## HTTP API listen address (default ":1633")
+# api-addr: :1633
+## initial nodes to connect to (default [/dnsaddr/bootnode.ethswarm.org])
+# bootnode: [/dnsaddr/bootnode.ethswarm.org]
+## enable clef signer
+# clef-signer-enable: false
+## clef signer endpoint
+#clef-signer-endpoint: /var/lib/bee-clef/clef.ipc
+## config file (default is /home/<user>/.bee.yaml)
+config: /etc/bee/bee.yaml
+## origins with CORS headers enabled
+# cors-allowed-origins: []
+## data directory (default "/home/<user>/.bee")
+data-dir: /var/lib/bee
+## db capacity in chunks, multiply by 4096 to get approximate capacity in bytes
+# db-capacity: 5000000
+## debug HTTP API listen address (default ":1635")
+# debug-api-addr: 127.0.0.1:1635
+## enable debug HTTP API
+# debug-api-enable: false
+## disable a set of sensitive features in the api
+# gateway-mode: false
+## enable global pinning
+# global-pinning-enable: false
+## NAT exposed address
+# nat-addr: ""
+## ID of the Swarm network (default 1)
+# network-id: 1
+## P2P listen address (default ":1634")
+# p2p-addr: :1634
+## enable P2P QUIC protocol
+# p2p-quic-enable: false
+## enable P2P WebSocket transport
+# p2p-ws-enable: false
+## password for decrypting keys
+# password: ""
+## path to a file that contains password for decrypting keys
+password-file: /var/lib/bee/password
+## amount in BZZ below the peers payment threshold when we initiate settlement (default 10000)
+# payment-early: 10000
+## threshold in BZZ where you expect to get paid from your peers (default 100000)
+# payment-threshold: 100000
+## excess debt above payment threshold in BZZ where you disconnect from your peer (default 10000)
+# payment-tolerance: 10000
+## ENS compatible API endpoint for a TLD and with contract address, can be repeated, format [tld:][contract-addr@]url
+# resolver-options: []
+## whether we want the node to start with no listen addresses for p2p
+# standalone: false
+## enable swap (default true)
+swap-enable: false
+## swap ethereum blockchain endpoint (default "http://localhost:8545")
+# swap-endpoint: http://localhost:8545
+## swap factory address
+# swap-factory-address: ""
+## initial deposit if deploying a new chequebook (default 100000000)
+# swap-initial-deposit: 100000000
+## enable tracing
+# tracing-enable: false
+## endpoint to send tracing data (default "127.0.0.1:6831")
+# tracing-endpoint: 127.0.0.1:6831
+## service name identifier for tracing (default "bee")
+# tracing-service-name: bee
+## log verbosity level 0=silent, 1=error, 2=warn, 3=info, 4=debug, 5=trace (default "info")
+# verbosity: info
+## send a welcome message string during handshakes
diff --git a/bee.yaml.sig b/bee.yaml.sig
new file mode 100644
index 000000000000..e3d318d01270
--- /dev/null
+++ b/bee.yaml.sig
Binary files differ