summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-01-21 19:43:40 +0100
committerhaawda2018-01-21 19:43:40 +0100
commit1de612ac6f6d3be80faecf502faff6f4e8079075 (patch)
tree4b5ddf32c1e8756da289ae31c561651b7f9a66a9
parent9ccdd70c6192af30237d7242e7687f7d3b1948db (diff)
downloadaur-1de612ac6f6d3be80faecf502faff6f4e8079075.tar.gz
update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--etcgobin4
3 files changed, 25 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 999e677ba0d2..84bf9ac94bc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = go-bin
pkgdesc = Compiler and tools for the Go programming language from Google
- pkgver = 1.5rc1
+ pkgver = 1.9.2
pkgrel = 1
url = http://golang.org/
arch = x86_64
- arch = i686
- license = BSD
- makedepends = git
- makedepends = go
+ license = custom
+ depends = bash
+ depends = perl
+ optdepends = java-environment: for running testsuite
provides = go
- conflicts = go
options = !strip
options = staticlibs
- source_x86_64 = https://storage.googleapis.com/golang/go1.5rc1.linux-amd64.tar.gz
- sha1sums_x86_64 = 2abf55effd93f5c2dcef306eaf14d3e7f614a407
- source_i686 = https://storage.googleapis.com/golang/go1.5rc1.linux-386.tar.gz
- sha1sums_i686 = 97ae55622479bbffaed893d72f699b32437acc8d
+ source_x86_64 = https://storage.googleapis.com/golang/go1.9.2.linux-amd64.tar.gz
+ source_x86_64 = etcgobin
+ sha1sums_x86_64 = 94c889e039e3d2e94ed95e8f8cb747c5bc1c2b58
+ sha1sums_x86_64 = 0428eb2625009006fe0a64883ec74f528c7a02c6
pkgname = go-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7b596c5850af..2d302a7ffd67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,21 @@
pkgname=go-bin
-pkgver=1.5rc1
+pkgver=1.9.2
pkgrel=1
provides=('go')
-conflicts=('go')
pkgdesc='Compiler and tools for the Go programming language from Google'
-arch=('x86_64' 'i686')
+arch=('x86_64')
url='http://golang.org/'
-license=('BSD')
-makedepends=('git' 'go')
+license=('custom')
+depends=('bash' 'perl')
+optdepends=('java-environment: for running testsuite')
options=('!strip' 'staticlibs')
-
-sha1sums_i686=('97ae55622479bbffaed893d72f699b32437acc8d')
-sha1sums_x86_64=('2abf55effd93f5c2dcef306eaf14d3e7f614a407')
-
-source_i686=("https://storage.googleapis.com/golang/go${pkgver}.linux-386.tar.gz")
-source_x86_64=("https://storage.googleapis.com/golang/go${pkgver}.linux-amd64.tar.gz")
+sha1sums_x86_64=('94c889e039e3d2e94ed95e8f8cb747c5bc1c2b58'
+ '0428eb2625009006fe0a64883ec74f528c7a02c6')
+source_x86_64=("https://storage.googleapis.com/golang/go${pkgver}.linux-amd64.tar.gz" etcgobin)
package() {
- mkdir -p $pkgdir/usr/local
- tar -C $pkgdir/usr/local -xzf go${pkgver}.linux-*.tar.gz
-
- # bin
- mkdir -p $pkgdir/etc/profile.d
- cat > $pkgdir/etc/profile.d/go-bin.sh <<-'EOF'
- #!/bin/sh
-
- export PATH=$PATH:/usr/local/go/bin
- EOF
+ install -d "$pkgdir"/opt
+ tar -C "$pkgdir"/opt -xzf go${pkgver}.linux-*.tar.gz
+ install -Dm755 "$srcdir"/etcgobin "$pkgdir"/etc/profile.d/go-bin.sh
+ install -Dm644 "$srcdir"/go/LICENSE "$pkgdir"/usr/share/licenses/go-bin/LICENSE
}
diff --git a/etcgobin b/etcgobin
new file mode 100644
index 000000000000..d638bf63fbaf
--- /dev/null
+++ b/etcgobin
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+export GOROOT=/opt/go
+export PATH=$PATH:$GOROOT/bin