summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-11-28 11:26:41 +0800
committerzxp198210052024-11-28 11:26:41 +0800
commitf2c54fc776310373b2097ddb5b67fec73469d8ee (patch)
tree9795edbe5bc63e7a619b470de842b836ee0d1cfd
downloadaur-f2c54fc776310373b2097ddb5b67fec73469d8ee.tar.gz
update to 0.10.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d04a5c065902
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = go-blueprint-bin
+ pkgdesc = Go-blueprint allows users to spin up a quick Go project using a popular framework.(Prebuilt version)
+ pkgver = 0.10.1
+ pkgrel = 1
+ url = https://docs.go-blueprint.dev/
+ arch = aarch64
+ arch = x86_64
+ license = MIT
+ provides = go-blueprint=0.10.1
+ conflicts = go-blueprint
+ source = LICENSE-0.10.1::https://raw.githubusercontent.com/Melkeydev/go-blueprint/v0.10.1/LICENSE
+ sha256sums = 8dbc61ccb9df6583bf6cd0ad23ca0a38e1eb0655f38eb85ec2b71b71392d5060
+ source_aarch64 = go-blueprint-0.10.1-aarch64.tar.gz::https://github.com/Melkeydev/go-blueprint/releases/download/v0.10.1/go-blueprint_0.10.1_Linux_arm64.tar.gz
+ sha256sums_aarch64 = 5a80e6018666c6b7418af59f620a033274b0390643fa0a8da3780ad72383e8b5
+ source_x86_64 = go-blueprint-0.10.1-x86_64.tar.gz::https://github.com/Melkeydev/go-blueprint/releases/download/v0.10.1/go-blueprint_0.10.1_Linux_x86_64.tar.gz
+ sha256sums_x86_64 = 83c43b467fed32a11a984d5478694ecf6220d622d9319b517434de80df2e8174
+
+pkgname = go-blueprint-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..536ee007a2c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=go-blueprint-bin
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="Go-blueprint allows users to spin up a quick Go project using a popular framework.(Prebuilt version)"
+arch=(
+ 'aarch64'
+ 'x86_64'
+)
+url="https://docs.go-blueprint.dev/"
+_ghurl="https://github.com/Melkeydev/go-blueprint"
+license=('MIT')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=()
+source=("LICENSE-${pkgver}::https://raw.githubusercontent.com/Melkeydev/go-blueprint/v${pkgver}/LICENSE")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar.gz::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_Linux_arm64.tar.gz")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar.gz::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_Linux_x86_64.tar.gz")
+sha256sums=('8dbc61ccb9df6583bf6cd0ad23ca0a38e1eb0655f38eb85ec2b71b71392d5060')
+sha256sums_aarch64=('5a80e6018666c6b7418af59f620a033274b0390643fa0a8da3780ad72383e8b5')
+sha256sums_x86_64=('83c43b467fed32a11a984d5478694ecf6220d622d9319b517434de80df2e8174')
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/completions/${pkgname%-bin}.bash" "${pkgdir}/usr/share/bash-completion/completions/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/completions/${pkgname%-bin}.fish" -t "$pkgdir/usr/share/fish/vendor_completions.d"
+ install -Dm644 "${srcdir}/completions/${pkgname%-bin}.zsh" "$pkgdir/usr/share/zsh/site-functions/_${pkgname%-bin}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}