summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Schoon2023-02-12 12:05:15 +0000
committerKevin Schoon2023-02-12 12:05:15 +0000
commit59e29c318c6dac114791289d9a37f1b463cbc127 (patch)
tree4c6d5c8429a47fb040b244909ca95839964adb5d
downloadaur-59e29c318c6dac114791289d9a37f1b463cbc127.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b704953b18c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = go-capnproto2
+ pkgdesc = Cap'n Proto library and code generator for Go
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/capnproto/go-capnproto2
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ depends = go
+ provides = go-capnproto2-git
+ conflicts = go-capnproto2
+ source = git+https://github.com/capnproto/go-capnproto2.git
+ sha256sums = SKIP
+
+pkgname = go-capnproto2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..44628303231b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.zst
+*.tar.gz
+src
+go-capnproto2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f88c55d4023a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kevin Schoon <me@kevinschoon.com>
+pkgname=go-capnproto2
+provides=('go-capnproto2-git')
+conflicts=('go-capnproto2')
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="Cap'n Proto library and code generator for Go"
+arch=('x86_64' 'aarch64')
+url='https://github.com/capnproto/go-capnproto2'
+license=('MIT')
+depends=('go')
+source=('git+https://github.com/capnproto/go-capnproto2.git')
+sha256sums=('SKIP')
+
+build() {
+ cd go-capnproto2/capnpc-go
+ go build -o capnpc-go
+}
+
+package() {
+ install -D -m755 \
+ go-capnproto2/capnpc-go/capnpc-go ${pkgdir}/usr/bin/capnpc-go
+ install -D -m644 \
+ go-capnproto2/std/go.capnp ${pkgdir}/usr/include/go-capnproto2/go.capnp
+ install -D -m644 \
+ go-capnproto2/LICENSE ${pkgdir}/usr/share/licenses/go-capnproto2/LICENSE
+}