summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsystem2016-02-08 14:29:32 +0100
committersystem2016-02-08 14:29:32 +0100
commit3ed8898feff9c82bc7bdbbf05422a07e5fa2214e (patch)
tree0f784de501b79d3861225b493524a161f292e315
parent69ddf6d400a1990f40bb383aecd9d6dd132082cf (diff)
downloadaur-3ed8898feff9c82bc7bdbbf05422a07e5fa2214e.tar.gz
Update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rwxr-xr-xgowrapper.sh2
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7181727fe371..f2496aa94ac5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Feb 8 12:49:31 UTC 2016
+# Mon Feb 8 13:29:20 UTC 2016
pkgbase = go-cross
pkgdesc = Compiler and tools for the Go programming language from Google (with cgo support for Windows, Android, Mac OS X and Linux)
pkgver = 1.6
@@ -25,7 +25,7 @@ pkgbase = go-cross
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 631b4144c6bf75bf7a4d480d685a9b5bda10ee8d03dbf0db829391e2ef858789
- sha256sums = 55f4a443cd63e7a685f95aaef4a8cd319b57607440b8373a040a7d0096af39c3
+ sha256sums = c4b9153cf7dfaf1d7f87509588d33d2e473d86af621fc461c91d6f864728120d
pkgname = go-cross
diff --git a/PKGBUILD b/PKGBUILD
index f5d7801620ab..de06ad5ce740 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ conflicts=(go)
provides=(go=1.6)
source=("$pkgname::git+https://github.com/golang/go.git" "osxcross::git+https://github.com/tpoechtrager/osxcross.git" "https://www.dropbox.com/s/yfbesd249w10lpc/MacOSX10.10.sdk.tar.xz" "gowrapper.sh")
noextract=("MacOSX10.10.sdk.tar.xz")
-sha256sums=('SKIP' 'SKIP' '631b4144c6bf75bf7a4d480d685a9b5bda10ee8d03dbf0db829391e2ef858789' '55f4a443cd63e7a685f95aaef4a8cd319b57607440b8373a040a7d0096af39c3')
+sha256sums=('SKIP' 'SKIP' '631b4144c6bf75bf7a4d480d685a9b5bda10ee8d03dbf0db829391e2ef858789' 'c4b9153cf7dfaf1d7f87509588d33d2e473d86af621fc461c91d6f864728120d')
build() {
cd "$srcdir/osxcross"
diff --git a/gowrapper.sh b/gowrapper.sh
index 118d6fcadd27..4653a31a946a 100755
--- a/gowrapper.sh
+++ b/gowrapper.sh
@@ -8,7 +8,7 @@ esac
export CGO_ENABLED=1
export PATH=/opt/go-cross/osx/bin:/opt/go-cross/ndk-x86/bin:/opt/go-cross/ndk-arm64/bin:/opt/go-cross/ndk-arm/bin:$PATH
export GOOS=${GOOS-linux}
-export GOARCH=${$GOARCH-amd64}
+export GOARCH=${GOARCH-amd64}
export CGO_LDFLAGS="-L/opt/go-cross/lib/$GOOS-$GOARCH"
export CGO_CFLAGS="-I/opt/go-cross/include/$GOOS-$GOARCH"
case "$GOOS" in