summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergely Imreh2019-05-18 11:10:55 +0100
committerGergely Imreh2019-05-18 11:10:55 +0100
commitf9af36794e3dbd38730b47fe63283a3348b92ad5 (patch)
tree75a04129eef601f6fc86947d48b6737c350ae207
parent69c01f65ec1d4d60f6ba11fd5bb3bd2ad08be16e (diff)
downloadaur-f9af36794e3dbd38730b47fe63283a3348b92ad5.tar.gz
Add missing dependency, and use precompiled proofs if no rustup
Signed-off-by: Gergely Imreh <imrehg@gmail.com>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7fa8beeb926..20441f5df668 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = go-filecoin
pkgdesc = A decentralized storage network, full node implementation in Go
pkgver = 0.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/filecoin-project/go-filecoin
arch = x86_64
license = MIT
license = Apache-2.0
makedepends = git
makedepends = go>=1.11.2
- makedepends = rustup
makedepends = pkgconf
makedepends = clang
+ makedepends = jq
+ optdepends = rustup: compiling proofs from scratch
conflicts = go-filecoin-git
source = git+https://github.com/filecoin-project/go-filecoin.git#tag=0.2.2
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5d857f8b4442..3bad12cafe5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,14 @@
pkgname=go-filecoin
pkgver=0.2.2
-pkgrel=1
+pkgrel=2
pkgdesc='A decentralized storage network, full node implementation in Go'
_organization='filecoin-project'
url="https://github.com/$_organization/$pkgname"
arch=('x86_64')
license=('MIT' 'Apache-2.0')
-#makedepends=('git' 'go>=1.11.2' 'rust>=1.31.0' 'pkgconf' 'clang')
-makedepends=('git' 'go>=1.11.2' 'rustup' 'pkgconf' 'clang')
-optdepends=()
+makedepends=('git' 'go>=1.11.2' 'pkgconf' 'clang' 'jq')
+optdepends=('rustup: compiling proofs from scratch')
conflicts=("${pkgname}-git")
source=("git+https://github.com/filecoin-project/go-filecoin.git#tag=${pkgver}")
@@ -44,9 +43,11 @@ build() {
msg2 'Installing dependencies...'
cd "$GOPATH/src/github.com/${_organization}/${pkgname}"
- # Use precompiled versions of proofs here
- export FILECOIN_USE_PRECOMPILED_RUST_PROOFS=true
- export FILECOIN_USE_PRECOMPILED_BLS_SIGNATURES=yes
+ if ! command -v rustup > /dev/null; then
+ echo "No rustup, will be using precompiled rust proofs and bls signatures."
+ export FILECOIN_USE_PRECOMPILED_BLS_SIGNATURES=yes
+ export FILECOIN_USE_PRECOMPILED_RUST_PROOFS=yes
+ fi
make deps
msg2 'Building binary...'