summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorObed N Munoz2020-08-07 12:49:21 -0500
committerObed N Munoz2020-08-07 12:49:21 -0500
commitdebd02d3a60932873c1cdefcf853c6b06183524e (patch)
tree33642d37fa2de86bab9c11241110afb6134e3d7a
parentde38ceb69fae0490afe1655bc6638b88a505208b (diff)
downloadaur-debd02d3a60932873c1cdefcf853c6b06183524e.tar.gz
Update package version methodology
Signed-off-by: Obed N Munoz <obed.n.munoz@gmail.com>
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afa0da617b83..c9b0f2b1e47e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = go-git
pkgdesc = Core compiler tools for the Go programming language
- pkgver = 2020.8.7
+ pkgver = go1.15beta1.r138.gba9e1088997
pkgrel = 1
epoch = 1
url = http://golang.org/
@@ -8,9 +8,12 @@ pkgbase = go-git
arch = x86_64
license = BSD
makedepends = git
+ makedepends = go
+ provides = go
+ conflict = go
options = !strip
options = staticlibs
- source = git+https://go.googlesource.com/go#commit=26957168c4c0cdcc7ca4f0b19d0eb19474d224ac
+ source = git+https://go.googlesource.com/go#master
md5sums = SKIP
pkgname = go-git
diff --git a/PKGBUILD b/PKGBUILD
index f0dea4b1ccae..e9c9ad282547 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@
pkgname=go-git
epoch=1
-pkgver=2020.8.7
+pkgver=go1.15beta1.r138.gba9e1088997
pkgrel=1
pkgrepo=go
pkgdesc='Core compiler tools for the Go programming language'
@@ -22,6 +22,8 @@ arch=(i686 x86_64)
url='http://golang.org/'
license=(BSD)
makedepends=(git go)
+provides=(go)
+conficts=(go)
options=(!strip staticlibs)
source=(git+https://go.googlesource.com/go#branch=master)
md5sums=('SKIP')
@@ -34,6 +36,11 @@ esac
export GOROOT_FINAL=/usr/lib/go
export GOROOT_BOOTSTRAP=/usr/lib/go
+pkgver() {
+ cd go
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
export GOROOT="$srcdir/$pkgrepo"
export GOBIN="$GOROOT/bin"