summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwicast2015-08-13 23:45:00 +0800
committerwicast2015-08-13 23:45:00 +0800
commit8c8b2b2ea19ba0201ef08fb0194aba8ccedfa6fd (patch)
tree7f533c3eeac927688aa4f1a12746b5b6966792c5
downloadaur-8c8b2b2ea19ba0201ef08fb0194aba8ccedfa6fd.tar.gz
Init
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0e933d8eb92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = go-gpm
+ pkgdesc = Barebones dependency manager for Go.
+ pkgver = 1.3.2.r10.g7db809e
+ pkgrel = 1
+ url = https://github.com/pote/gpm
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = go
+ source = go-gpm::git+https://github.com/pote/gpm.git
+ md5sums = SKIP
+
+pkgname = go-gpm
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8121b149542
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: philanecros <philanecros@gmail.com>
+
+pkgname=go-gpm
+pkgver=1.3.2.r10.g7db809e
+pkgrel=1
+pkgdesc="Barebones dependency manager for Go."
+arch=("any")
+url="https://github.com/pote/gpm"
+license=('MIT')
+groups=()
+depends=("go")
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("$pkgname::git+https://github.com/pote/gpm.git")
+md5sums=('SKIP')
+noextract=()
+
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --tags --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ # avoid conflict with existing core/gpm package
+ make DESTDIR="$pkgdir/" exec="go-gpm" install
+}