summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Sztandera2016-07-03 19:42:19 +0200
committerJakub Sztandera2016-07-03 19:42:19 +0200
commitda84d9cfa8aa893bf8ce0ef587fa214df93ccbfb (patch)
treef0c9dd97871e29f5d8564947913cfb5e4aad8979
parent4bc2217358412e14459269ddef8ab072d99aec14 (diff)
downloadaur-da84d9cfa8aa893bf8ce0ef587fa214df93ccbfb.tar.gz
Bump version, add note about migrations
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--go-ipfs-git.install10
3 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0937f3c42819..19929df45c7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Tue May 17 20:44:13 UTC 2016
+# Sun Jul 3 17:42:02 UTC 2016
pkgbase = go-ipfs-git
pkgdesc = global versioned p2p merkledag file system
- pkgver = 0.4.2.r0.g41c5e11
+ pkgver = 0.4.3dev.r0.g50a7df6
pkgrel = 1
url = https://github.com/ipfs/go-ipfs
+ install = go-ipfs-git.install
arch = i686
arch = x86_64
arch = armv7h
@@ -17,8 +18,10 @@ pkgbase = go-ipfs-git
conflicts = go-ipfs
source = git+https://github.com/ipfs/go-ipfs.git
source = ipfs.service
+ source = go-ipfs-git.install
sha512sums = SKIP
sha512sums = 1a6bc7fffc3c3640cda3f33c107424edd698c62bd8509731856b8827ea18be1a1845ef0d5ca15325d48d7d871a78daacc011ff9eacea926bc35899850990c1c6
+ sha512sums = 563b104c389115fc360315e6b798f058c2429a8d5d95b070db538870e801e6ee03ade42f2c0207dccdc222297f6d74d5e77ff38ad470b9a3e446a6fe169c906e
pkgname = go-ipfs-git
diff --git a/PKGBUILD b/PKGBUILD
index 483f1ed797e3..d8ebc2f1538b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=go-ipfs
pkgname=$_pkgname-git
-pkgver=0.4.2.r267.g50a7df6
+pkgver=0.4.3dev.r0.g50a7df6
pkgrel=1
pkgdesc='global versioned p2p merkledag file system'
url="https://github.com/ipfs/$_pkgname"
@@ -15,9 +15,12 @@ optdepends=('fuse: for mounting/advanced use'
'bash-completion: bash completion support')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+${url}.git" "ipfs.service")
+source=("git+${url}.git" "ipfs.service" "go-ipfs-git.install")
+install="$pkgname.install"
+
sha512sums=('SKIP'
- '1a6bc7fffc3c3640cda3f33c107424edd698c62bd8509731856b8827ea18be1a1845ef0d5ca15325d48d7d871a78daacc011ff9eacea926bc35899850990c1c6')
+ '1a6bc7fffc3c3640cda3f33c107424edd698c62bd8509731856b8827ea18be1a1845ef0d5ca15325d48d7d871a78daacc011ff9eacea926bc35899850990c1c6'
+ '563b104c389115fc360315e6b798f058c2429a8d5d95b070db538870e801e6ee03ade42f2c0207dccdc222297f6d74d5e77ff38ad470b9a3e446a6fe169c906e')
pkgver() {
cd "$srcdir/$_pkgname"
diff --git a/go-ipfs-git.install b/go-ipfs-git.install
new file mode 100644
index 000000000000..be8fa00d5765
--- /dev/null
+++ b/go-ipfs-git.install
@@ -0,0 +1,10 @@
+post_upgrade() {
+ OLD="$2"
+ NEW="$1"
+
+ if [ $(vercmp "0.4.3dev" "$OLD") -gt 0 ]; then
+ echo "IPFS repo format hash changed."
+ echo "You will have to run migrations tool."
+ echo "See: https://github.com/ipfs/fs-repo-migrations/"
+ fi
+}