summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-03-01 11:38:08 -0500
committerTony Lambiris2017-03-01 11:38:08 -0500
commitc694614c84a11cde9cc07e0146226a7972d84435 (patch)
tree6fa7ba086a46db43a4f912523f7ce1ea5c905e97
downloadaur-c694614c84a11cde9cc07e0146226a7972d84435.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d00e52f9e7a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = go-kbdgrab
+ pkgdesc = Key grabber written in golang for cleaning your keyboard
+ pkgver = r2.3e6676f
+ pkgrel = 1
+ url = https://github.com/tonylambiris/go-kbdgrab
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = go
+ source = git+https://github.com/tonylambiris/go-kbdgrab.git
+ md5sums = SKIP
+
+pkgname = go-kbdgrab
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..355d18b889e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=go-kbdgrab
+pkgver=r2.3e6676f
+pkgrel=1
+pkgdesc='Key grabber written in golang for cleaning your keyboard'
+arch=(i686 x86_64)
+url='https://github.com/tonylambiris/go-kbdgrab'
+license=(BSD)
+makedepends=(go)
+source=("git+https://github.com/tonylambiris/go-kbdgrab.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -m755 -D kbdgrab "${pkgdir}"/usr/bin/kbdgrab
+}