summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAvinash H. Duduskar2021-09-30 11:53:21 +0530
committerAvinash H. Duduskar2021-09-30 11:53:21 +0530
commit659f14283d1eea152464f83cd9c940cc308c038b (patch)
tree7287883276dd9f21be88ab866f9bf1515ebb342d
downloadaur-659f14283d1eea152464f83cd9c940cc308c038b.tar.gz
First commit for go-livepeer-bin
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
-rw-r--r--livepeer.service32
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea819bbd5e76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = go-livepeer-bin
+ pkgdesc = Official Go binaries of the Livepeer protocol
+ pkgver = 0.5.21
+ pkgrel = 1
+ url = https://github.com/livepeer/go-livepeer
+ arch = x86_64
+ license = MIT
+ conflicts = go-livepeer-git
+ source = https://github.com/livepeer/go-livepeer/releases/download/v0.5.21/livepeer-linux-amd64.tar.gz
+ source = livepeer.service
+ sha256sums = aa966e0af5599faf04d1c9334da36f59e3f6007ca23fc0f21c7c2379b998f0e4
+ sha256sums = 19f2c69e7f84e32236fe7f46a9b969cbe2f936651a1a50b818279fdd7299da3b
+
+pkgname = go-livepeer-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb0e671ba8e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Strykar <strykar@hotmail.com>
+
+pkgname=go-livepeer-bin
+_pkgname=go-livepeer
+pkgver=0.5.21
+pkgrel=1
+pkgdesc='Official Go binaries of the Livepeer protocol'
+arch=('x86_64')
+url='https://github.com/livepeer/go-livepeer'
+license=('MIT')
+conflicts=('go-livepeer-git')
+source=("https://github.com/livepeer/${_pkgname}/releases/download/v${pkgver}/livepeer-linux-amd64.tar.gz"
+ "livepeer.service")
+sha256sums=('aa966e0af5599faf04d1c9334da36f59e3f6007ca23fc0f21c7c2379b998f0e4'
+ '19f2c69e7f84e32236fe7f46a9b969cbe2f936651a1a50b818279fdd7299da3b')
+package() {
+ install -Dm 755 "${srcdir}/livepeer-linux-amd64/livepeer" "$pkgdir/usr/bin/livepeer"
+ install -Dm 755 "${srcdir}/livepeer-linux-amd64/livepeer_bench" "$pkgdir/usr/bin/livepeer_bench"
+ install -Dm 755 "${srcdir}/livepeer-linux-amd64/livepeer_cli" "$pkgdir/usr/bin/livepeer_cli"
+ install -Dm 755 "${srcdir}/livepeer-linux-amd64/livepeer_router" "$pkgdir/usr/bin/livepeer_router"
+ install -Dm 644 "$srcdir/livepeer.service" -t "${pkgdir}/usr/lib/systemd/system"
+}
diff --git a/livepeer.service b/livepeer.service
new file mode 100644
index 000000000000..3f2af23fe149
--- /dev/null
+++ b/livepeer.service
@@ -0,0 +1,32 @@
+[Unit]
+Description=Start the Go-Livepeer service
+After=network.target
+Wants=network-online.target
+# See https://www.cyberciti.biz/faq/linux-hide-processes-from-other-users/
+
+[Service]
+Restart=always
+Type=simple
+
+ExecStart=/usr/bin/livepeer -network mainnet -orchestrator -transcoder \
+ -maxSessions $sesh -cliAddr $cliadr -nvidia all -ethAcctAddr $ethaddr \
+ -ethPassword $ethpass -ethUrl $ethurl -pricePerUnit $unitprice \
+ -serviceAddr $serviceaddr -maxGasPrice $maxgas -reward=$rew -monitor=$mon
+
+
+# Update the ENV VARS below with your information
+# Then run: sudo systemctl daemon-reload && sudo systemctl enable --now
+
+Environment='ethaddr=0x1a00000000000000000000000000000000000000'
+Environment='ethurl=https://mainnet.infura.io/v3/00000000000011111111110000000000'
+Environment='unitprice=800'
+Environment='serviceaddr=my.livepeer.node:8935'
+Environment='ethpass=mywalletpassword'
+Environment='maxgas=40000000000'
+Environment='sesh=6'
+Environment='cliadr=10.10.10.1:7935'
+Environment='rew=false'
+Environment='mon=false'
+
+[Install]
+WantedBy=multi-user.target