summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAvinash H. Duduskar2021-10-01 13:51:24 +0530
committerAvinash H. Duduskar2021-10-01 13:51:24 +0530
commit6b8143fed96ef0db4c7c16ee627b28b1ee36ac0e (patch)
tree1d925cf960f3371bd959af5a1c28852628ce29b4
parent9e39added01af1dbda98263430d93870700ce69f (diff)
downloadaur-6b8143fed96ef0db4c7c16ee627b28b1ee36ac0e.tar.gz
Set backup for config in PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rw-r--r--livepeer.service4
3 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e91056484f57..f420d9ed364f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = go-livepeer-bin
provides = go-livepeer
provides = go-livepeer-bin
conflicts = go-livepeer
+ backup = etc/go-livepeer/environment
source = https://github.com/livepeer/go-livepeer/releases/download/v0.5.21/livepeer-linux-amd64.tar.gz
source = https://raw.githubusercontent.com/livepeer/go-livepeer/master/LICENSE
source = environment
@@ -15,6 +16,6 @@ pkgbase = go-livepeer-bin
sha256sums = aa966e0af5599faf04d1c9334da36f59e3f6007ca23fc0f21c7c2379b998f0e4
sha256sums = c4de4cf3034bc69b6832f22ea3e18957639e41f2ad7d4cfed6919f6e0dbf99ba
sha256sums = dfe28d5e3ff4cdd384f873ab767ca40a49aad7e282a42898469b20c4b5167d56
- sha256sums = f7af239c0ff3ec8cd7d69d75f8e3073e42dce2a87ffda1cc6a21ce3e0b97859c
+ sha256sums = 09f42fd378e629b220d68905b492536276f7980274a0930d92e9d63b0b5a27b2
pkgname = go-livepeer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 660332f53f8a..a8c46bdf5eab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ pkgdesc='Official Go binaries of the Livepeer protocol'
arch=('x86_64')
url='https://github.com/livepeer/go-livepeer'
license=('MIT')
+backup=('etc/go-livepeer/environment')
conflicts=('go-livepeer')
provides=('go-livepeer' 'go-livepeer-bin')
source=("https://github.com/livepeer/${_pkgname}/releases/download/v${pkgver}/livepeer-linux-amd64.tar.gz"
@@ -17,7 +18,7 @@ source=("https://github.com/livepeer/${_pkgname}/releases/download/v${pkgver}/li
sha256sums=('aa966e0af5599faf04d1c9334da36f59e3f6007ca23fc0f21c7c2379b998f0e4'
'c4de4cf3034bc69b6832f22ea3e18957639e41f2ad7d4cfed6919f6e0dbf99ba'
'dfe28d5e3ff4cdd384f873ab767ca40a49aad7e282a42898469b20c4b5167d56'
- 'f7af239c0ff3ec8cd7d69d75f8e3073e42dce2a87ffda1cc6a21ce3e0b97859c')
+ '09f42fd378e629b220d68905b492536276f7980274a0930d92e9d63b0b5a27b2')
package() {
install -Dm 644 "${srcdir}/environment" -t "${pkgdir}/etc/${_pkgname}"
install -Dm 644 "${srcdir}/livepeer.service" -t "${pkgdir}/usr/lib/systemd/system"
diff --git a/livepeer.service b/livepeer.service
index 47171cccc5b9..3abf48170a94 100644
--- a/livepeer.service
+++ b/livepeer.service
@@ -11,9 +11,9 @@ Type=simple
EnvironmentFile=/etc/go-livepeer/environment
ExecStart=/usr/bin/livepeer -network mainnet -orchestrator -transcoder \
- -maxSessions $sesh -cliAddr $cliaddr -nvidia $nvd -ethAcctAddr $ethaddr \
+ -maxSessions $sessions -cliAddr $cliaddr -nvidia $nvidia -ethAcctAddr $ethaddr \
-ethPassword $ethpass -ethUrl $ethurl -pricePerUnit $unitprice \
- -serviceAddr $serviceaddr -maxGasPrice $maxgas -reward=$rew -monitor=$mon
+ -serviceAddr $serviceaddr -maxGasPrice $maxgas -reward=$reward -monitor=$monitor
[Install]
WantedBy=multi-user.target