summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorguns2017-09-12 12:59:09 -0500
committerguns2017-09-12 13:19:46 -0500
commit0e29d199656946c30e20e399ca0b1935af0e13b7 (patch)
treeb836f3fe99a01f259d62a607d4c9f52e441ffbc6
downloadaur-0e29d199656946c30e20e399ca0b1935af0e13b7.tar.gz
Add AUR packaging
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD31
-rw-r--r--install17
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fdcba2a1446
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = go-luks-suspend
+ pkgdesc = Encrypt LUKS volumes on system suspend
+ pkgver = 1.3.8
+ pkgrel = 1
+ url = https://github.com/guns/go-luks-suspend
+ install = install
+ arch = x86_64
+ license = GPL3
+ makedepends = go
+ depends = systemd
+ depends = cryptsetup
+ depends = mkinitcpio
+ conflicts = arch-luks-suspend
+ conflicts = arch-luks-suspend-git
+ source = https://github.com/guns/go-luks-suspend/archive/v1.3.8.tar.gz
+ sha1sums = b441120a0cb5c0ed54b3c60624536717e48a48d5
+ sha256sums = 271b351004241500399c3f9256ecf65a3362977f7887f650f4cfce4c97f81b0e
+ sha512sums = 577a151b5bdc94bc3b7d25b879524e66949062f273131bdb0b07f81c6989727f89eba223988c672d073d1a8e5dcbc793bdeb4412f1cd2b23034759f97f9f716b
+
+pkgname = go-luks-suspend
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1dfde1b09c4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/bin/
+/pkg/
+/src/
+/*.pkg.*
+/*.tar.gz
+/go-luks-suspend
+/initramfs-suspend
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb550341a2c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: guns <self@sungpae.com>
+# Contributor: Vianney le Clément de Saint-Marcq <vleclement AT gmail·com>
+pkgname=go-luks-suspend
+pkgver=1.3.8
+pkgrel=1
+pkgdesc='Encrypt LUKS volumes on system suspend'
+arch=('x86_64')
+url='https://github.com/guns/go-luks-suspend'
+license=('GPL3')
+depends=('systemd' 'cryptsetup' 'mkinitcpio')
+makedepends=('go')
+install=install
+conflicts=('arch-luks-suspend' 'arch-luks-suspend-git')
+source=("https://github.com/guns/$pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('577a151b5bdc94bc3b7d25b879524e66949062f273131bdb0b07f81c6989727f89eba223988c672d073d1a8e5dcbc793bdeb4412f1cd2b23034759f97f9f716b')
+sha256sums=('271b351004241500399c3f9256ecf65a3362977f7887f650f4cfce4c97f81b0e')
+sha1sums=('b441120a0cb5c0ed54b3c60624536717e48a48d5')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ make clean all
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/install b/install
new file mode 100644
index 000000000000..bbfbc76ebdd9
--- /dev/null
+++ b/install
@@ -0,0 +1,17 @@
+post_install() {
+ echo '1) Enable the udev, encrypt, shutdown, and suspend hooks'
+ echo ' in /etc/mkinitcpio.conf and run `mkinitcpio -p linux`'
+ echo '2) Enable the go-luks-suspend service with:'
+ echo ' `systemctl enable go-luks-suspend.service`'
+ echo '3) Reboot'
+}
+
+post_upgrade() {
+ local oldver="$2"
+ if (("$(vercmp "$oldver" "1.2.0-1")" < 0)); then
+ echo '[ATTENTION] go-luks-suspend must now be explicitly enabled!'
+ echo '[ATTENTION] Run `systemctl enable go-luks-suspend.service` to enable it.'
+ fi
+}
+
+# vim:set ts=2 sw=2 et: