summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMcNoggins2015-06-11 21:39:17 -0400
committerMcNoggins2015-06-11 21:39:17 -0400
commit17f644b62930e05f1fe2d38885e3d08d9701b44a (patch)
treef30077c26cd5af509b10f0c56c74cb787194d2fc
downloadaur-17f644b62930e05f1fe2d38885e3d08d9701b44a.tar.gz
Initial aur4 import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b370e248956a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = go-mtpfs-git
+ pkgdesc = Simple tool for viewing MTP devices as FUSE filesystems
+ pkgver = 20141215
+ pkgrel = 1
+ url = http://github.com/hanwen/go-mtpfs
+ arch = x86_64
+ arch = i686
+ license = BSD
+ makedepends = go>=1.3.0
+ makedepends = git
+ depends = libmtp
+ depends = fuse
+ options = !strip
+ options = !emptydirs
+ source = git+https://github.com/hanwen/go-mtpfs.git
+ md5sums = SKIP
+
+pkgname = go-mtpfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3791497d5ad8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: Whitney Marshall <whitney.marshall@gmail.com>
+# Maintainer: McNoggins <Gagnon88 (at) gmail (dot) com>
+
+pkgname=go-mtpfs-git
+pkgver=20150424
+pkgrel=1
+pkgdesc="Simple tool for viewing MTP devices as FUSE filesystems"
+arch=('x86_64' 'i686')
+url="http://github.com/hanwen/go-mtpfs"
+license=('BSD')
+depends=('libmtp' 'fuse')
+makedepends=('go>=1.3.0' 'git')
+options=('!strip' '!emptydirs')
+source=("git+https://github.com/hanwen/go-mtpfs.git")
+md5sums=("SKIP")
+_gourl=github.com/hanwen/go-mtpfs
+
+pkgver() {
+ # Use date of latest commit for pkgver
+ cd "$srcdir/go-mtpfs"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+build() {
+ cd "$srcdir"
+ # Build using go
+ GOPATH="$srcdir" go get -v -x ${_gourl}
+}
+
+check() {
+ GOPATH="$GOPATH:$srcdir" go test -v -x ${_gourl}
+}
+
+package() {
+
+ # Package license (if available)
+ for f in LICENSE COPYING; do
+ if [ -e "$srcdir/src/$_gourl/$f" ]; then
+ install -Dm644 "$srcdir/src/$_gourl/$f" "$pkgdir/usr/share/licenses/$pkgname/$f"
+ fi
+ done
+
+ # Package executables
+ if [ -e "$srcdir/bin/go-mtpfs" ]; then
+ install -Dm755 "$srcdir/bin/go-mtpfs" \
+ "$pkgdir/usr/bin/go-mtpfs"
+ fi
+} \ No newline at end of file