summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2019-10-16 05:56:34 -0400
committerJoey Dumont2019-10-16 05:56:34 -0400
commit75f4edbf55c41fd3feba05ee77e56db9d4a1a514 (patch)
tree7a8f788a6e260d47db8ccc0de87f7fe096a0f52b
parentb72fad19e95f072cfad01f1ce724be11c7d29a6c (diff)
downloadaur-75f4edbf55c41fd3feba05ee77e56db9d4a1a514.tar.gz
Updated to support go modules.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1833e802a5a..68100cbd4911 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = go-mtpfs-git
pkgdesc = Simple tool for viewing MTP devices as FUSE filesystems
- pkgver = 20150917
+ pkgver = 20190802
pkgrel = 1
url = http://github.com/hanwen/go-mtpfs
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8c8ba452afba..1e841d01b269 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Maintainer: Joey Dumont <joey.dumont@gmail.com>
# Contributor: Whitney Marshall <whitney.marshall@gmail.com>
-# Maintainer: McNoggins <Gagnon88 (at) gmail (dot) com>
+# Contributor: McNoggins <Gagnon88 (at) gmail (dot) com>
pkgname=go-mtpfs-git
-pkgver=20150917
+pkgver=20190802
pkgrel=1
pkgdesc="Simple tool for viewing MTP devices as FUSE filesystems"
arch=('x86_64' 'i686')
@@ -24,7 +25,8 @@ pkgver() {
build() {
cd "$srcdir"
# Build using go
- GOPATH="$srcdir" go get -v -x ${_gourl}
+ go mod init hanwen/go-mtpfs
+ go get -v -x ${_gourl}
}
package() {