summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2020-02-14 21:15:10 -0500
committerJoey Dumont2020-02-14 21:15:10 -0500
commit7eb0ae7a2e5b4909f57a673d1cf558dd4c8761fa (patch)
tree4a8ff46115d469d1532c6f93b6b929bcdac3d2a0
parent75f4edbf55c41fd3feba05ee77e56db9d4a1a514 (diff)
downloadaur-7eb0ae7a2e5b4909f57a673d1cf558dd4c8761fa.tar.gz
Fixed build.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD25
2 files changed, 7 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68100cbd4911..a8f81a7117d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = go-mtpfs-git
pkgdesc = Simple tool for viewing MTP devices as FUSE filesystems
- pkgver = 20190802
+ pkgver = 20200111
pkgrel = 1
url = http://github.com/hanwen/go-mtpfs
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1e841d01b269..e32e1cc6e72b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Joey Dumont <joey.dumont@gmail.com>
# Contributor: Whitney Marshall <whitney.marshall@gmail.com>
# Contributor: McNoggins <Gagnon88 (at) gmail (dot) com>
+# Contributor: Hielke Christian Braun <hcb@unco.de>
pkgname=go-mtpfs-git
-pkgver=20190802
+pkgver=20200111
pkgrel=1
pkgdesc="Simple tool for viewing MTP devices as FUSE filesystems"
arch=('x86_64' 'i686')
@@ -14,7 +15,6 @@ makedepends=('go>=1.3.0' 'git')
options=('!strip' '!emptydirs')
source=("git+https://github.com/hanwen/go-mtpfs.git")
md5sums=("SKIP")
-_gourl=github.com/hanwen/go-mtpfs
pkgver() {
# Use date of latest commit for pkgver
@@ -23,24 +23,11 @@ pkgver() {
}
build() {
- cd "$srcdir"
- # Build using go
- go mod init hanwen/go-mtpfs
- go get -v -x ${_gourl}
+ cd "$srcdir/go-mtpfs"
+ go build ./
}
package() {
-
- # Package license (if available)
- for f in LICENSE COPYING; do
- if [ -e "$srcdir/src/$_gourl/$f" ]; then
- install -Dm644 "$srcdir/src/$_gourl/$f" "$pkgdir/usr/share/licenses/$pkgname/$f"
- fi
- done
-
- # Package executables
- if [ -e "$srcdir/bin/go-mtpfs" ]; then
- install -Dm755 "$srcdir/bin/go-mtpfs" \
- "$pkgdir/usr/bin/go-mtpfs"
- fi
+ install -Dm644 "$srcdir/go-mtpfs/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$srcdir/go-mtpfs/go-mtpfs" "$pkgdir/usr/bin/go-mtpfs"
} \ No newline at end of file